Duplex Mismatch

Is there some issue with Moto (Canopy, PTP400) connected to Cisco switches?
I have both (PTP400 and Cisco) in Auto Speed Auto Duplex… and I see the following error:

23w1d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/15 (not half duplex), with SEP0023542B03C6 Port 1 (half duplex).

The utp cable is brand new AMP 5e shielded. I also try with common cable not shielded, and always i get the same issue.

I have the same problema with Canopy BH20 and Cisco switch. Is there kind of known issue?
Anybody can help with that, please?

Thanks in advance,


Force both ends to 100/Full - should do the trick. I always disable auto negotiation where I can.

Yes… but Im afraid if I hard code 100FD on both end, and there is any problem Ill lost the radio and have to climb the tower…


Try forcing the swith to 100FDX. The AP should connect in auto.

If one end is 100FDX and the other is auto, the auto end will select 100HDX and you will encounter frame errors and collisions.

I don’t mean to sound snarky or anything, but if you force both ends to 100FDX and the link doesn’t come up, then that would indicate a cabling issue or port issue that would require servicing anyway.

Personally I would start with 10 half and go up from there just to make sure I can access it with all port configs before jumping into the problem.

I did it… Now I put in 100FD both end, and still the same issue…
We provide VoIP and with PTP400 with 11mbps of downlink there is no chance to keep the ethernet link in 10mbps.

And you did force the cisco to full duplex instead of half? and it still says duplex mismatch? have you tried plugging the ptp400 into a laptop to see if it matches the duplex on both ends?

Yes… It seems like Cisco have some problema with duplex.

10 half works most of the time when i connect cisco to the SM

You guys are ALL missing the point here.

"23w1d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/15 (not half duplex), with SEP0023542B03C6 Port 1 (half duplex)."

This means that SEP00blah, which is a Cisco VOIP phone, is sending out CDP packets to the network saying that it’s half duplex. The fact that your router has a FULL duplex connection to the Orthogon is why it thinks there is a problem.

If the Cisco VOIP phone was plugged into a Cisco switch then the CDP packets would never make it to the Cisco router and you wouldn’t see this message. The router expects that CDP packets are only from a directly connected device since a Cisco switch would have filtered them out.

As long as the Cisco and the Orthogon report no ethernet interface errors, or at least if they’re both reporting full duplex, then there was no auto-negotiation problem.

Basically, this message means nothing. Just disable CDP on the phone and/or the router. You can do it on the phone with the TFTP config file. You can do it on the router with ‘no cdp run’ as a global command.

Oh my… :oops: You are quite correct. And to think I’ve run into this very issue on my own desk with a 2950 and a 7960.

twinkletoes is very much correct - somewhere connected to that switch is another switch that is not eating CDP and a phone is responding to it. Since the PTP radios aren’t running CDP, you’d see something like “Interface FastEthernet0/20 is experiencing errors” with a lot of retransmits and checksum problems.

Sorry for misleading you. You can also disable CDP on a per-interface basis with “no cdp enable”.