E400 and E410 Poor range and Speeds

I have a E410, and an E400, both on the recommended firmware versions, updated this morning. 3.11.4.1-r3
We have long had an issue with Android devices (Notes and Fan Edition S20) not switching between 5ghz and 2.4ghz very well. We have them connected to a Gigabit switch. Also range seems OK, but the speed drops massively within a very short distance from the AP’s. For example, down a hallway which is probably 7m, I am only getting around 60Mbps and once I move from there to right in front of the AP I seem to only get 140Mbps or so. I do have two SSID’s a Mixed 5/2.4 and a 2.4 only one for my dumb devices that can’t connect to a dual band set up.
Band Steering is set to normal on both.
RF Quality are showing at 70/74% respectively, and 20 and 80mhz for the 2.4 and 5 bands respectively.

Any ideas what I can try?

Could you please check if clients are connected in 5GHz when they are near AP and what is the RSSI reported.

So, an interesting thing. If I turn off wireless and on again on my note 20, it goes from connected at 104Mbps standing right beside it, to 866Mbps. It happens on both my wifes Samsung S20 FE and my note, pretty much identical. Both AP’s have a similar thing happening.

On Android, how do I show whether I am connected at 2.4 or 5?

How do I check the RSSI?

Please SSH to AP and capture output of “show wireless clients” or you can get same information from cnMaestro in Clients tab.

1 Like

Go to developer mode, enable WiFi debuging :slight_smile:

1 Like

Hi. So, I have an E410 downstairs in my lounge, and a E400 upstairs. It seems when sitting in my office downstairs, it connects to the upstairs one, at 2.4ghz and -78rssi and even if I go and stand near the downstairs e410, it doesn’t switch over to using the I am standing next to! If I turn off WiFi on my phone, it then seems to connect to the one I am standing closest to at 5Ghz

Please enable “Enhanced roaming” which enables forced client disconnection.

  • This will help you to disconnect client if RSSI/SNR is below configured values.

  • This feature helps you to connect to better AP.

I have enabled that and left the Roam of 15SNR as the default? If that is correct, then unfortunately, that didn’t seem to help. If I go into my office, my speeds drop to <65Mbps and if I then go and walk under the ground floor AP, it doesn’t change significantly, perhaps to 110Mbps?

Strangely, when in my office on the ground floor, it wants to connect me primarily to the upstairs AP, and I’m guessing it can’t get enough 5Ghz signal and sits me on the 2.4Ghz band.

With additional testing, if I sit in my office, turn off wifi on my note 20 and then turn it on again, I momentarily get a 5Ghz connection to the upstairs AP, then it more or less immediately drops down to 2.4ghz ~117Mbps connection

Recommended value is 25dB (RSSI=-70) and 30dB (RSSI=-65) for better performance.

Thanks, I have changed those settings. Still getting around 74Mbps in my office, but speeds are better elsewhere in the house. Not amazing, but OK ish?

Anything else I can try to try and get 5Ghz range better?

OK, an unintended consequence is that my mobile phone is semi frequently disconnecting from the wireless. This is bad for my mobile gaming

I assume you have 5G set to max power. If you want best range use the 20MHz channel BW. In terms of orientation the AP’s are designed for maximum antenna efficiency out the front cover of the device so ceiling and wall mounting the radiation pattern is best out the front (logo) vs. backside.

Greetings

Sorry for the lengthy post !

Has there been any solutions proposed ? I have a similar issue at a Church and am seriously interested in this thread - Following !

Cut down on power no difference
Changed Channels - no difference

We have tried almost everything mentioned above as well and had to revert back to the new wireless router … Took me a while to id the issue as We had to perform traces logs etc. to find that the AP was disconnecting and settling down to 2.4G randomly as well - Note : We found a Windows 10 Pro issue with WIFI Settings / 5G set up on the PC and it seems to be stable connecting to 5G but still disconnecting occasionally ( Note We live Stream services and disconnecting is not good ! ) . Our issue is randomly bandwidth would go from over 900 to 500 to 100 to 10 to 2.5 and then gone . Approx 20 feet away from the AP and it is pointing outwards towards the middle of the Church hall : The AP is @ 90degrees and the pc is approx 300 degrees pointing towards the AP ( Compass heading ) Using a TP LINK High speed wifi 5G USB adapter . Tested out the adapter and not one issue with it found as In Our lab speeds on the pc over a gig and no drops . Serious 500 gig uploads and downloads to an FTP site ! Temporarily now the streaming has had no issues since we removed the AP ! If any sort of logs or traces it is difficult as we cannot replicate the issue after hours as we have tried extensively !

can you share some pictures of the installation?

I will post some photos, but essentially the E410 downstairs is fastened to the roof in a central part of the house. Upstairs, it was sitting on the top of a desk inside a room around about central to the upstairs area.

There appear to be two issues for me:

Connecting to E4xx with Samsung/Android Devices, the device will drop to 2.4g as it has a stronger signal, but never recovers automatically back to 5ghz when back in range of the 5ghz network.

The second issue appears to be with range. I have increased the range from auto to 21 and it made no discernable difference.

Using WiFi Analyser there is no 5Ghz signal available in my downstairs office, and the 2.4 is really low as well, despite being 6m as the crow flies from the AP downstairs and probably about the same from the upstairs. We have moved the AP upstairs out of the room and temporarily into the hallway and things are better.

I need to turn off the auto disconnect thing on low signal as multiple people are complaining about frequent loss of wireless connectivity for 10 seconds every now and then.

This just doesn’t feel seamless and the way wireless should work.

It’s possible the construction of the house may prevent a good wireless signal, though it’s a brick and tile home less than 15 years old, but the fact the devices don’t switch nicely between 2.4 and 5g doesn’t feel like it’s working well.

Was this ever resolved? I am having a similar issue with an E410 and an E600.

Could you please brief the issue you are facing.

Please tell more about models of this devices.
For ex. Samsung support mesh starting from s9 and newer.
Old devices has a lot problems with switching from 2,4 to 5.

@CAM_TSK Thank you for your reply and I apologize for late response.

So I have raised a ticket with support but still in the process. I have a customer with a large home and I installed a e600 and an e410 to cover the home. So the first thing they are experiencing is poor throughput performance on either end of the house, one is the master bedroom and the other is a spare bedroom. The spare bedroom is not very far from the one AP, e410, and the Master bedroom is not very far from the other AP, e600.

The customer is seeing poor throughput on multiple devices, iphone, ipad and an android phone. My suspicion is that when they are in one area the device is not “hopping” over to the closer AP. One thing I am also noticing is some of the home wifi devices, which never move(ie Garage Doors) have a very poor RSSI/SNR to the AP they are connected to. I did set up a WLAN group up and so there is only one SSID to connect to with both AP. I must of misconfigured something wrong, any suggestions?

Thanks again!

@DigitalMan2020

Please enable enhanced roaming feature. Default value is 15dB, which means any client SNR less than 15dB, AP will send de-authentication, which will force client to connect to other AP.