E600 won't turn on after firmware update

Hi. Yesterday I updated the firmware of the E600 access point, everything seems to go well, the firmware version changed in the web interface. I turned it off overnight, but when I came in the morning and turned it on, it wouldn’t turn on.

The LED on the case doesn’t light up at all. There is no network access. The access point gets a little warm when plugged in.

I tried doing a reset by holding down the button, but that didn’t work. I also tried switching to the old firmware on and off the access point 8 times, but that didn’t work either (I’m not sure if I did it right).

There doesn’t seem to be a problem with the injector. I tried plugging in the power supply, but that didn’t work.

Is it a dead end? Or is there anything else I can try to do?


Please confirm the status of LEDs on injector before and after plugging in e600.

Thank you.

LED lights blue in both cases.

Please check if you are able to ping “default IP” or “Zero Conf IP”. Please refer “chapter 2” of Userguide and confirm if device is accessible.

UserGuide: https://support.cambiumnetworks.com/files/cnpilot-tech-ref/archive#r1

I don’t have any network access. The link is down.

We have guidelines to upgrade and downgrade the E600 AP. As per cambium’s recommendation, Please use the cnMastro to upgrade and downgrade the E600.

Please refer to the release note.

I don’t see how this can help me. My access point seems to be completely broken.


Please raise a support ticket and they will guide you with next steps.


You need to raise suppot ticket for RMA.

Thank you.