Encrypt Fail when starting session?

I have a 450i AP at v15.2.1 trying to connect to a 450i SM at v15.2.0

I get an "Encrypt Fail" message when trying to start the session. I am using a pre-shared key and AES128. If I turn off encryption, but leave authentication on, the sessions joins successfully.

I haven't tried updating the SM yet, but do the AP and SM need to be on the same version for encryption to work? Or do I have a different problem?

15.2.1 and 15.2 should work fine. Did you double check that the SM has the same preshared key as the AP entered and is set to AES-128?

1 Like

Yes, and like I mentioned the authentication is working so I assume that means they are using the same pre shared key.

Do you know what can cause the “Encrypt Fail” message? I don’t understand how authentication can succeed and encryption fail when using a pre shared key


My suspicion is a config issue, they should work together OK, I'd like to check please.

Could you grab a engineering.cgi from both AP & SM and forward them to me?

bacuffe1 at cambiumnetworks dot com




I got it working now, the only thing different really is that I assigned an IP to the SM. When I tried before the SM had no IP assigned. Could that make a difference? Or was I just having bad luck before?