ePMP 3000 AP manual upgrade to V4.7 hangs on ulboot upload

Upgrade from 4.6.2 to 4.7.0 was initiated from the web page using the ePMP-AC-v4.7.0.img downloaded from support, upload was successfull but the upgrade hung on uboot ulpoad and does not advance or recover. After this the web access is not possible with any username or password it sais password incorrect. How can I recover from this without a truck roll?

Did you try rebooting it via cnMaestro?

We had a number of radios which just loop around and present us with the “disable these accounts” question over and over, and won’t proceed past that. But we are able to reboot them from cnMaestro and then the next time they were okay.

Try to reboot them by SSH

I have tried rebooting via cnMaestro and now the units show they are offline but they were never rebooted and the same phenomenon still exists where one cannot log into the web interfase as it sais password incorrect. The active sessions are still active and users are still up, but I have effectively lost all access to the AP.

Any other suggestions?

SSH access no response from the radios to open the session.

Use to be able to reboot the radios via SNMP. Back in the v3 days there was a few periods/versions where the interface and SSH became unaccusable fairly frequently. We ended up creating a web page were we could just go enter the IP of the radio in question and reboot it via SNMP.

I do not remember what mibs we used and I haven’t tried to reboot a radio via SNMP in years so I don’t know if it is broken in v4 or is even still possible but it use to be. Also if you were using the default SNMP strings then I believe v7 shuts of remote SNMP access automagically.

Edit: Did they remove support for ePMP from CNUT ? If not then you can possibly use CNUT ( Cambium Network Updater Tool) to connect to / reboot the radios.

Thanks for the TIP, just tried CNUT with SNMP access and no luck…even though these 2 radios did not complete the upgrade to 4.7.0 and are still 4.6.2 and have non standard SNMP read and write strings set up but there is also no SNMP response from them…so I think the truck roll is eminent and hopefully these units are recoverable.

Hi. Did you also try cnMaestro or SSH? I’ve been able to reboot ePMP radios with cnMaestro which I was otherwise unable to log into.

1 Like

Yes, you can use CNUT to reboot ePMP radios and I just recently used it to push many hundreds of 4.7-STA firmware updates to N and AC SM’s and AP’s. You’ll need to request a .pkg3 format however. ALSO, the computer you use to push out the updates has to be directly reachable by the radios on the network. If you try behind NAT, it will not work properly because CNUT incorrectly tells the radios to download the update from the CNUT computer’s private IP address instead of the upstream/public IP address.


Thanks for the tip, excellent feedback. In this case specifically I had to do a truck roll. The radios recovered immediately with a hard restart and at first when they did recover I thought something was wrong with them seeing that I had created an update task in cnMaestro which now with the new feature of when an upgrade is not successful leaves it flagged with “Upgrade the next time the uit come back online” feature so in my case after about a minute of the radio coming back online it registered with cnMaestro and got the update and restarted again which obviously initially threw me off as the radio became unresponsive for the restart…but all good it was only the pending upgrade. So all good and now I did the second upgrade and everything back to normal. Thanks for the community help here.