Epmp 3000L no longer work and POE indicator light blinks


I am looking for a solution to a problem that we have been having for a while. We have a lot of AP epmp 3000L 5Ghz access point radio which stopped working. And we notice that the POE Led flashes continuously.
Does anyone have an explanation or a solution to suggest?

I believe a blinking light means the power supply is overloaded and that means either the power supply is bad or the radio it is powering is damaged (drawing to much current from short in radio ?).

Could be a short from a bad connector end. I’d replace the lower one first in hope that’s the bad end… It could be the power supply but more likely a bad end.

i took down the radio and use another cable but its not changing a thing. These are several radio

The problem is not related to POE because I tried with many other PoE

Did you have any type of a surge issue (i.e. lightning strike?) Were these grounded for installation? If you would like we could take one unit back, evaluate the problem and report back to you.

Probably lightning or other power surge fried the radios.

Christian, If you can easily get a radio down, test it with a known good short cable. If it doesn’t work, send it in to have it checked. If it does, then you may have too much resistance in the tower cable. Could be low quality cable, bad connector attachment, bad surge protector, or a combo.
Start with as much as possible known and eliminate unknowns until you find the issue. Can be difficult sometimes.


Same exact symptoms. 12 Fried radios on one tower. Had to buy a whole new set. Oddly, the equipment at the base of the tower that those radios were plugged into was fine. Either lightning or static did all 12 in and we still haven’t figured that out.

The same problem is also happening with us. 1 of our new epmp3000l devices did not work in any way, the device does not turn on. One of them turned off by itself 2 hours after it worked, we had to change the device. We have more than three hundred epmp3000l in stock and we are concerned that the number of problematic devices will increase. No lightning has happened, temperature is around 35 degree celcius in country

I have repaired a few ubiquiti app’s with this exact problem. It was due to over voltage causing a Schottky diode to go short circuit. An easy fix if you can find it with a multimeter. I’ve got a 3k at home, I’ll see if I can find the diode and send a pic if your interested.

1 Like

I also had a 3000L faulty which didn’t come back to life after updating firmware to its second bank. The issue is there is no even 1 epmp 3000L in Australia hence if another of my 3000L fails I’m dead. A real stock problem.

Same issue multiple times. I just configured a Force-300-16 and when I unplugged it to move it to the other side of the room for testing it would not power. I tried multiple POE injectors, multiple power cables, multiple outlets and multiple patch cables. This is at least the second time this has happened to me and it is very frustrating.

This usually happens when the ethernet line transformer inside the radio gets cooked or the isolation capactors become shorted. Causes as Brubble pointed out an over current ussue. They need to be sent off to be repaired (unless out of warranty and you have those skills available).

Now the root cause: are these being killed on the same tower? If so what are they plugged into? Do you have any LPUs? Do you have a floating ground system or any ground loops? Do you have a 6ft aerial above your antenna? Ifbyour not at the top of the tower then are you using the ESD ground to follow your cables down? If so move them now! Best place for a cable is up the inside of a leg away from the ESD ground.

1 Like

Hi Anthony,
I will love to see how you go it RESOLVED.
In my own case, when the Radio (Force 180) is plugged to the POE, the POE indicator keeps blinking.