ePMP elevate for Nano Station Loco M5 XW firmware

Hello everyone,

Please I am trying the ePMP elevate software for the very first time on a ubiquiti Loco M5 XW device and its not being successful. I initially tried it with the ubiquiti device still on a software version of 6.1.1 and I got the error message "firmware image check failed. Error code: 43".  I have downgraded the Loco M5 version to 5.6.1 and this time I have the message "This firmware is not trusted by airOS. To maintain security, it will not be loaded. Please load trusted firmware". I have tried both ePMP elevate software versions 3.4.1 and 3.5. 

Please I would appreciate help from anyone with a similar experience.



Due to UBNT now requiring the use of signed firmware going forward from 6.0.6, it is now (slightly) more difficult to downgrade.

Two firmware downgrades must be used to use unsigned firmware. The steps are:

1. Downgrade to 6.0.6-beta
2. Downgrade to 6.0.4 (unsigned)

3. At this point you can load whatever older or unsigned  3rd party firmware you'd like


Thanks Eric. But at this point where can I download 6.0.6 beta? is it available on the ubnt site??



See THIS thread in the UBNT forums for information on the firmware.


Thanks Eric. With the steps you provided I have been able to complete the elevation process successfully.

Best regards,



Great! I'm glad your issues have been eleviated :-)

1 Like

Hola a todos,

Realice el procedimiento y me subio el firmware de elevate, el radio me responde ping pero no me ingresa a la interfaz web

Alguien sabe que puedo hacer para solucionar?

la mejor respuesta clara y conreta encontrada!!!