ePMP Force 180 JSON


I need to import a JSON configuration in my ePMP Force 180 with a CLI command.

Some documentation explain this command:

config input <URL>

When I send this command:

config input

the ePMP not return any error message but nothing change into my configuration.

How to update configuration using hosted json configuration? 

Hi Daniele,

you can use the following command to check for errors:

config import errors

Please also check that you can ping and settings.json is available.



Thanks for reply.

Yes I’ve used the error check function and not error found.
Obviously I’ve cheched the connection between device and webserver: all work fine (ping and json syntax).

Can you please check HTTP server logs if device is downloading config file. Can you please also share config file you are using.



For me the problem stay behind the Cambium firmware because all my approch was inconcludent, I need to know the right method to use this config input function bad documented.

I did not wrote specifically all my tests. Today I've tried to use FTP approch (only because surfing in internet I've found some information about it).

Summarizing: for both protocols I've used nothing of positive.

I tried to start an FTP server and use this sintax:

config import ftp://username:password@

Nothing change and FTP server log not shown any from (Cambium device).

Ping from Cambium loacalhost ssh to reply normally.

Tested with filezilla client and with manual telnet commands: the server work fine.


I tried to start an HTTP server and use this syntax:

config import

Nothing change and HTTP log not shown any from (Cambium device).

Ping from Cambium loacalhost ssh to reply normally.

Tested with browser and with manual telnet command: the server work fine.


Other little test was try to set this "config input" value behind SNMP protocol but nothing happens.


Speaking about the configuration file, yes I can of course post my file but..

  1. This file is only a backup of original configuration with some little changes to see differences post-import.
  2. The sintax of my file as 100% correct: tested with chrome javascript console and one online tester tool.
  3. The logs shown that this hosted file was NEVER downloaded/parsed from the device.

Thanks in advance for every idea :)

Just wanted to clarify if you're using "config input <url>" or "config import <url>"...


Sorry newkirk,

I wrote an error and I've correct the previous post :)

Hello Daniele,
I have not found any issues with JSON Configuration file upload to Force 180 board.
Could you please verify you can upload that configuration file via GUI(Tools -> Backup/Restore -> Restore Configuration) without errors.


Also please check you have correctly configured permissions for configuration file.
Thank you.