ePMP Syslog not working on Force 300-13L (version: 4.6.1)

This feature isn’t working for me, is there any well-known bug? (This comment was originally posted on: ePMP: Configuring AP System Logging (Syslog))

For more context: I’ve an rsyslog server in which I’m collecting logs, I tried to enable the logserver in a Force 300-13L device but isn’t working, despite reboots and different levels of logging I’m not receiving anything.

I tried to enable this feature on a cnPilot device and it’s working properly.

So, I’m wondering if there is any bug on the ePMP firmware?

Are you entering an IP address or a hostname for the syslog server? If it’s a hostname, could you try an IP address instead?

I’m using an IP address that is reachable for the SMs (I checked it with ping and traceroute)

I assume there’s nothing in the on-device logs to suggest why it’s not working?

The only other thing I can suggest is running a packet capture to see if there are any syslog packets coming out at all.

I recommend raising a ticket:

I will raise a ticket. A couple of questions before doing so:

  1. Is the only think I have to do to “enter the IP” and save and reboot? (Do I need to reboot?)
  2. Is ePMP using the default 514 port? UDP or TCP?

Thanks!

I don’t know the answer to either of these, I’m afraid. I would guess that it uses the standard port, based on this;

…but I don’t know if it is UDP or TCP. This post suggests that it is UDP port 514:

syslog can use either udp or tcp on port 514.

Syslog as a service yes, but who knows what protocol is the ePMP firmware using to send traffic.

I’m fairly certain it’s UDP.