ePSK with Mikrotik Configuration

Hello, so I’m running into an issue when connecting to an SSID - more specifically not obtaining an IP for the right VLAN associated with the ePSK. We currently have 12 SSID’s broadcasting, and I’m consolidating them into 1 and I have an external DHCP server (Mikrotik) and have the appropriate VLAN’s configured for it to egress through the switch, AP and down to the client:


The problem I’m having is I believe trunking the ports, for all above VLAN’s. We have a total of 12 AP’s on prem managed by cnMaestro. My “uplink” port is port 15, that port directly connected to the MK interface which is eth3.

I have created an AP group:

And a switch group:

Now where I’m lost is, tagging the right port (uplink #15) or all together (all ports) the switch to carry those VLAN’s to the AP’s. Here’s what I currently have for port #15.

ePSK does work when connecting to the SSID with any of the 12 generated keys, but the IP isn’t obtaining - and I’m sure I’m confusing myself with how to carry those VLAN’s down to the end-user.

Anything look odd here?


Do U have DHCP server (configuration) for each VLAN on Mikrotik ?

Are you running a DHCP per vlan on the Mikrotik or running a relay agent ?
I have a very similar design at a customer and its worked since the inception of ePSK. Their switches are all Mikrotik but it shouldn’t really affect the configuration that much.If you assign yourself a static in the mapped range can you see the gateway address ?

Hey Kris,
The Switch Group is for the cnMatrix switches which I believe you don’t have in your setup. You seem to be having bunch of cnPilot devices running 4.X firmware and connected to the Mikrotik router. It does seem you have some misconfiguration in your setup. From the AP ethernet port 1 configuration it seems ok to me.

Can you do one thing, have a simple wpa2-psk WLAN and configure the VLAN 2750 on it. Now your clients should get an IP from this VLAN which is being served by your Mikrotik router which is supposed to run a DHCP server for this VLAN.

If it still doesn’t work then please debug the DHCP packets from the AP interface and your Mikrotik router and see who is not either passing the DHCP packet or not responding to it. Once you have this working then ePSK clients using this VLAN should work and hopefully by then you will know what was wrong and fix for all the other trunked VLAN’s.

Hope it helps else ping us and we can have a call to help you out.

1 Like

Did you untag or PVID a port on the switch and get an IP from the right VLAN?

1 Like

I did the small scale test here.

Tik has 2 VLANS. Vlans are both through my switch to the e410. If I use the epsk key… I get an IP from VLAN 254. If I use the default password… i get an IP from VLAN 1.