Error: Changes could not be saved as the profile is invalid


I'm using cnMaestro (2.2.1-r5) with a cnPilot 600 connected to a cnMatrix EK2010-P onboarded. 

I'm able to configure Basic, Management, Radio setting but when I try to configure Network parameters (e.g. VLANs, DHCP pools,....) I get the error message "Changes could not be saved as the profile is invalid". Does anyone experienced the same problem?

My cnMaestro account is super-administrator for that system. If i configure the Networks settings from the web GUI of the device everything works correctly.

Can you please send us a screenshot of your "Network" configuration page?


please find the attached files. Everything is set as default but when I try to change any of the settings I get the error message.



Are you able to create a new AP Group, apply the changes and see if you get the same error?

If you do get the same error can you screenshot the setting you have applied that is causing the error. That way I/we can take a look and try to replicate the issue.

- I created a new AP Group named "test", moved the E600 to that group

- I tried to change a radio setting, e.g. channel bandwidth and it was changed correcty

- I tried to create a VLAN 10 as see in the attached file but I got the usual error message

I've copied the VLAN settings from your screenshot in my instance of cnMaestro.

Initially I was able to save the settings without issue. However when I removed the WLAN (within the basic tab) I was able to recreate the error message you recevied.

Can I please ask do you have a WLAN selected?


WLAN is set according to the attached file.

When creating the it by selecting "Add WLAN", the only available was "Default Enterprise" as shown by the third screenshoot.


I'm wondering if there is a problem with the WLAN you have selected?

Could you try and create a new WLAN (Configuration > WLANs and AP Groups).

Once the new WLAN is created could you go back to your AP Group, remove the "Default Enterprise" WLAN and add the new WLAN.

I was thinking at the same problem; I removed that WLAN and created a new one as per attached file but still I get the same error message.

Umm that's a strange one, I'm not sure why you're getting the issue then. It mgiht be worth raising a support ticket with Cambium it sounds like a bug to me.

Ok many thanks, 

I will open a support request and go back to you with the reason of the issue.

Thanks anyway for the time dedicated and for your help.



When there is this error when saving an AP Group a red /!\ icon usually appears on the left side next to the section that is configured incorrectly.  Within that section the field(s) that are invalid should be highlighted.

Try expanding the sub-sections of the Network tab out by clicking the plus [+] icons.  Sometimes the browser's password autofill tries to enter the password in a non-expanded section.  Are any fields highlighted red?  If so, these need to be fixed. 

If it was due to browser auto-fill then they could just be deleted.

1 Like

Hi Jordan,

many thanks for your reply.

There is a <!> icon next to the Network menu but there are no red boxes in any field unfortunately so I'm not able to find where the issue is.



Click the [+] next to Access Control List to expand those set of fields out.  Also scroll down and expand all other sections.  This will show you all possible fields.  There may be one that is highlighted after expanding everything out.

Dear Jordan,

thanks a lot for the suggestion.

The problem was that the browser pre-filled the fields "password" that found in the page, even if a section was not marked or enabled. The other fields were empty so the program indicates the error.

By removing the pre-filled field or filling the other empty fields the error was solved.

Thanks and regards



Glad you got it working Piero!

Within you browser's settings/options there should be a section to Manage Passwords or Manage Logins.  You may be able to make adjustments there to prevent the password auto-fill after logging in to cnMaestro or remove it completely to prevent this from happening again.

Thanks for the suggestion, I prevented filling of password on cnMaestro site and the browser doesn't fill anymore that fields.

Thanks again



Many thanks!

You just saved the day, after couple of hours banging my head against the keyboard. Suddenly  I'm starting to hate the browser autofill :)