Error in template

We have a template for managment vlan and ip programming, it has worked fine all the time.

Untill update on cnm. No changes has been made to the template, but now it say fault in device variables.

Any suggestions? Here is the template we use.

"device_props": {
"mgmtIFEnable": "1",
"mgmtIFVLAN": "1",
"mgmtIFVID": "${MGMTVLAN}",
"mgmtIFVP": "1",
"mgmtIFIPAddressMode": "1",
"mgmtIFIPAddr": "${IP_ADDRESS}",
"mgmtIFNetmask": "",
"mgmtIFGateway": "${GATEWAY}"


I have made our product team aware of this and they will be responding soon.


Is the error seen when trying to apply the configuration?  Check that the device replacement variables are correctly entered for all replacement variables that do not have a default.

There is also a known issue where templates with replacement variables cannot be applied at the device level.  This is being tracked in issue CNSSNG-4319.  The issue only appears at the device level.

As work around for that issue is to navigate to a higher level in the left-hand tree (tower, network, system) and create the job from there. 

Thank tou for the reply.

The error is after i save the configuration. When we push "add configuration job" on the device level.

So this is linked to your tracked issue.

Thank you for the work around. Going to a higher level worked fine.

im having this error on some SM

......{"device_props": {"systemConfigDevice

Hi Jose,

Can you please let us know whether the problem is with he template creation or with the template pushing to device.

Can you pleae share the error you are seeing and also the template you are using.



its when pushing to device but only about 3 give me this error out of 400 SM's

Hi ,

Can you please share the template you are using and what are the type of SMs you are using especially the 3 SMs on which the template push is failing.