ethernet LAN speed R200p


I have one R200p configured as WAN IP mode PPPoE. The WLAN works perfect and when I make a speedtest, the throughput is arround 80Mbps downlink and 30 Mbps uplink, that are the values expected taking into account my connection.

However, when I make the same test directly connected to the ethernet LAN ports of the units, the maximum throughput is lower than 500kbps. We have made the same test with several laptops.

The firmware version is the latest 4.3.1 software.

Do you know where is the problem?



Can you please check whether the internet  VLAN idex is 1st  in WAN->INTERNET tab?

You should put  internet VLAN as first WAN connection.


I have created only one WAN connection, for management, Internet and Voice. I have attached a screen capture of the WAN configuration.


VLAN ID is  set to 0, can you please check this and correct to the vlan id that you are using.


why I have to configure a VLAN?. The VLAN mode is disabled because I need that the WAN port data arrives to this interface as untagged. I receive the PPPoE perfectly and I can navigate using WLAN. Which is the different between WLAN and ethernet LAN interfaces in this case? The behaviour of the WAN should be the same in both situations...


I have tried with the same WAN interface configuration like yours with single management-internet-voice profile in PPPoE mode and VLAN mode disabled. I'm getting good speed on LAN side with downlink and uplink.

Can you please share your device config file, so that i can load that and check.


I have attached the actual configuration file.


file attached

Hi We did not see speed test issue with your attached configuration(Device Firmware Details : 4.3.1-R1201612201723) It seems there is issue with Ethernet interface of device. To verify Ethernet Lan issues, Please run speed test on another R200 device with your configuration or run LAN throughput test as per below procedures. Procedure to run LAN throughput test. 1. Configure device in default mode. 2. Connect two LAN PCs to Ethernet interface of device. 3. Run Iperf traffic test in between two LAN PCs. Note: I have attached the network diagram for LAN throughput test.

I have made the test you suggest in the LAN network. The throughputs are 95Mbps Full duplex.

However, if I made a speedtest or I try to navigate to internet directly connected to the ethernet port, the throughput problem remains.

I have made several test:

- I have created a PPPoE connection in my ethernet interface and the throughputs are correct (you can see attached picture)

- I have connected to the wireless interface of the R200p with the WAN configuration I sent you, and the throughputs are correct again.

- I have connected to the ethernet interface with different laptops and the throughput is lower than 500Kbps.

I have made a downgrade from firmware 4.3.1 to 4.2.3 and the problem is still the same.

I have reset the unit to factory default to configure it again, and the problem remains.



I´m making test with your R200p unit. The throughput for the download speed is much lower than the expected value. However, for the upload speed the throughput is perfect (arround 90Mbps).

I have made several test, connected to the ethernet LAN port and to the WLAN SSID. With WLAN, works better, but I only have 25Mbps in a 100Mbps Internet connection. For the ethernet LAN is even worst (lower than 1Mbps). We have tested it with several laptops and we have allways the same resutls.

The unit has the 4.3.1 firmware version and the only configuration different from the default is that I have configure PPPoE and the account.

I have tested exactly the same internet connection with a different Router (DLINK) and it works perfect (90Mbps for download and 90Mbps for upload).


Try "set to factory defaults", sometimes messing with advanced features makes strange behavior

I have done several resets to factory default, but it doesn´t solve the problem. I have made another test:

- A Force200 configured as NAT and receiving PPPoE.

- The R200p WAN as bridge.

With this configuration it works perfectly.


Hi Smartinez,

Sorry  for the delay in responding. You have tried all  the possible combination to resolve this issue.

Please share your  email Id and  arrange remote session to resolve/debug this issue ASAP.



Hi Niraj,

my email is


Curious to see if this issue was resolved and if so, what was the fix? Thanks


I appreciate your patience, we are actively working to root cause this issue, but are still not there.

Shall try to resolve the issue at the earliest.



Has there been any movement on this?

Hi  tmeads307 ,

Are you facing simillar issue ?  Can you describe what issue are you facing and in which firmware version .



Hi Nilesh, it is pretty much the exact same issue, on the latest firmware version and we have an open case going.  You can PM or email me for the details.