Ethernet link problem in canopy 5.7GHz SM

I have been using 5.7GHz SM with 40m long cat5 UTP cable and normal switch to connect other computer to internet for 3 years. Now it suddenly stop working. I cannot even ping SM’s IP. When I plug in the ethernet jack of the SM to computer I can establish the link but when I put it in switch port I can’t.
I even tried by putting it to 10Base mode, but still no success. While using short cable it works fine in both switch and computer. The problem is with the long cable. remember earlier it was working fine with long cable and I haven’t changed any settings too.

What should be the problem??? :cry: :frowning:

It’s possible that the cable is broken or shorted somewhere inside, or at the ends. Have you tried an ethernet cable tester on it?

BTW I have this tester and consider it good:

We have this problem too.
After 1-2 hours of work connection from side of Ethernet is lost. We can see SM from RF, it is registered on АР, but is not present Ping from Ethernet
Connection is restored only after reboot the module or on’off power switch. We tried to replace SM, the cable, then SS 300, the switchboard - helps nothing. In what there can be a problem?

try running cable straight from the sm to switch, if this works then you know the problem is with the surge suppressor.