EX2010-P doesn't start console


we have tried to upgrade a cnmatrix EX2010-P to 3.0.1.-r4.img from 2.0-r1 following this post:


When we upgraded switch by using this command:

download agent sftp://user:user@

it was blocked for a while and we have tried to reboot switch by power cord; after it doen't restart and from console we saw attached state; pls have you an idea to solve this issue ?

Thank you in advance, Francesco.


Sorry to hear you have problem with cnMatrix. It looks like the flash image is corrupted. Please raise a support ticket to RMA the switch. 

Thank you.

We have not been able to reproduce the symptoms:

1) switch is unresponsive while downloading the image using sftp

2) switch no longer boots after software upgrade from 2.0-r1 to 3.0.1-r4

For 1), did you execute the command 'download agent sftp' inside ssh session or inside the console connection? The console connection uses the serial cable to connect the PC and the serial connector on the switch.

If the download command is issued inside SSH session, with SFTP there is no 'progress' status updated on the display until download completion, and this can take a little while depending on the downloading speed. However, if you are using TFTP as in CLI command 'download agent tftp://', the display will continuously show the percentage download progress.

If you have requested an RMA for the switch, can you please provide the RMA# for my tracking.

Thanks & Regards.