EX2010-P no PoE with XV2-2

Hi Cambium community,

I came across something which doesn’t make sense to me: (maybe I’m missing sth.?)
XV2-2 AP is not powering up on EX2010-P Switch.

According to specs this sould work? (802.3at, 30W max / port)
When connecting a Yealink T48s or Ruckus R610 on the same cable, no problems.
Tried different ports and different cables (and different firmware both on switch and ap) - no luck.
No other PoE devices connected.

With a 48V PoE injector the AP powers up instantly.

Any ideas on this?

Thanks in advance,


Can you share the AP (XV2-2) and the Switch (EX2010-P) version.

I’ve a switch (cnMatrix EX2010-P) running Software version: 4.1.1-r2 which is giving power to AP (XV2-2 ) running Software Version:6.4.1-r4 running in the LAB.


Hi Anand,

thanks for your reply and the confirmation that it should work.

tried switch firmware: 4.2.1-r5 + 4.1.3-r1 + 4.0.1-r2
AP: + 6.4.1-r15

I’m now back to AP , Switch 4.1.3-r1 (current recommended)

I managed to get my hands on another XV2-2 which worked!
So it’s “just” some hardware Problem on the AP, 802.3af/at negotiation I guess.
The “broken” ap only works with 48V passive PoE.