Force 400C how to disable autonegotation for AUX/SFP port?

Hi, I need to fix AUX/SFP speed port to 1GFull, in my Force 400C.
In Gui was not present any configuration option for this.
I’ve tried via SSH with the command:
config set networkLan2AutoNegotiation 0
config set networkLan2Speed 1000
but without success, also after config commit and reboot.
After this configuration it’s appeared another line in Aux port config in Configuration-Network GUI (in attacchment).
FW 5.3.0 (but i’ve tested other fw with same results)
I need to do this beacause the SFP interface it’s connected to a sfpplus port in Mikrotik router.
To fix the speed 1G FDX only in the router did not works.
Thanks for your help!

SFP ports are always autonegotiation mode. Rather not possible to fix.
Maybe your sfp modul is not supported ?

In ePMP3000 it’s possibile to negotiate SFP port!
This configuration force400 and same sfp module it’s also used in other scenarios and it’s working fine. Now i need to negotiate sfp port due to mikrotik problem with sfp-plus port.

Its possible to negotiate an sfp port only if the gbic supports multiple speeds.
Check your gbics and make sure you have two identical gbics or it will not work right.

With epmp3000 and the same identical gbic it’s possible to negotiate the sfp port. With 400c it’s impossibile… my gbic supports negotiation, i’ve multiple identical installed.

Idk then, we are using 1gbps non negotiating gbics and never had a problem. With the sfp to copper gbics we do get negotiation but I havent tried on in a f400c (might not get it back out!) yet.

Manual configuration mode for SFP+ port is coming in the next firmware version.
It will be available from UI.
As of now you can try export configuration file from the device and look for auxiliary port related options and set the needed configuration. Then import the configuration file back to the device.

Thank you.

Not working via ssh and not working via export/modify/import configuration…
I’m waiting new firmware, I hope it will be released soon…

1 Like

In the UI, backup your config as readable text file. Edit the file for the aux port with needed settings, restore config from edited file. Reboot

I’ve made, modified json and re-imported, but not working.

Double check your file for spelling, spacing and brackets. Do this using windows notepad (notepad++ sometimes changes characters sets too) and definitely not on a macOS machine. If using linux use either VIM or Nano.
The commands you place do have an order to be applied and is important that they are correct for the radio and firmware you are using. So a config from a epmp3000 will be largely ignored on a force400c.
You must power cycle (not simply reboot) to enforce your imported config. For some reason after an import config is written to the radio a simple reboot does not tend to work properly, the radio will come up but not everything is as expected, but a full power cycle does work.

Hi @sommodeo,
I’ve researched your question. SFP+ does not really care in general what you set in the software. All control nobs and parameters are artifacts.
A pair of SFP+ transceivers just establishes the link. It looks absolutly the same in Mikrotik routers as well. You can try to set different speed and duplex. Let’s say it is a technical progress: SFP+ works on it own in the best way.

Could you tell me why do you need to do it?

1 Like

I need to do this because on some Mikrotik with sfp-plus slot, it’s necessary to fix negotiation to 1G fdx to establish the link. In some mikrotik models, the link it’s established but traffic not passing.
I’ve this scenario with many ePMP3000, and I need to fix negotation to work correctly. (only on SFP+ slot on mirkotik. If the MT slot it’s sfp 1G it’s not necessary to fix negotiation)