GPS general communication error

A week after deployment I had epmp GPS unit drop all of its clients.  When I logged in it showed the GPS as down.  I tried to change a few settings and I also tried to upgrade the firmware and the GPS firmware.  The GPS firmware wouldn't update, it kept giving a gps general communication error.   Do I need to replace the unit?

Hi Chris, 

There is known issue with the "old" GPS firmware (AXN_1.51_2801) where the GPS chip locks up and stops communicating with the SoC. This is what I suspect you are experiencing. In order to recover this, you will have to power cycle (hard reboot - not just soft reboot from the GUI or CLI) to reset the GPS chip so it starts communicating with the SoC again. Once the GPS chip is up, you should then upgrade the GPS firmware so the chip is running AXN_1.51_2838. With this new firmware the issue will be resolved and there will be no more lock ups. 

Instructions to upgrade the GPS firmware and troubleshooting tips are detailed in the Release notes. Search for "Upgrading the on-board GPS chip firmware" in the Release Notes or User Guide for instructions. 




Hello, I checked "Upgrading the on-board GPS chip firmware" but can not find where to download the file with the firmware.

Where I can download it?

Thank you,


You should use Main FW file.

Then uplod in on Tools Software Upgrade page in GPS Firmware section.

Thank you.

1 Like