GPS upgrade and reboot not working on 4.4.2

Hello. We've upgraded an AP to 4.4.2 which is a 2k AP and we are unable to upgrade the GPS firmware.

I've attached a screenshot showing the error message when we try to upgrade the GPS firmware with the 4.4.2 file. Once that error showed up, GPS sync also says it's down but 4 customers are still connected.

We're also unable to reboot the radio using the GUI after the attempted GPS upgrade. It acts as if it has rebooted but it doesn't and the uptime does not reset.

Anyone still seeing bugs with this release?

Thank you

Ok more weird issues.

After I couldn't get it to reboot with the GUI, I tried upgrading the 2nd bank to 4.4.2 as well and it didn't work but it appears to have rebooted from that upgrade which is unusual. Upon logging back in, the uptime was 40 seconds so it rebooted but the 2nd bank is still on 3.5.6 and did not upgrade.

BUT the GPS firmware shows it is now up-to-date which should not be possible since it never actually completed the upgrade before.

Can someone take a look at this for me? I'm afraid to upgrade our network now that I've found at least 3 bugs or more just on the first sector I upgraded.

Hi Darin,

I'm really sorry to hear you faced issues with 4.4.2.

The issue with GPS FW upgrade is GUI issue.

GUI is showing wrong warning message, but GPS FW upgrade is actually running in background.

GPS FW upgrade can take up to 10-15 minutes, reboot through the GUI doesn't work during this period of time.

Is the board still in the state when you are not able to reboot it?

We would be glad to take a look if shh access to the radio works.

Feel free to reach me directly at fedor.trutsko(at)cambiumnetworks(dot)com.

Thank you.

We rebooted the AP with our Netonix after 5-10 minutes and maybe that's why it came online with the correct firmware after that.

It's working properly now.

I'll upgrade a few more and see if they work better.

Thank you


Please keep as updated in casee of any issues.

Thank you.

I tried upgrading a brand new out of the box 2k AP today to 4.4.2 both banks. Then did the GPS upgrade again and it said it was not required so I waited 7 minutes before power cycling the POE.

When the AP came back online, I receive the following error message in the log: No GPS information received from device. Power reset is required.

I have power cycled it 2 times now and still receive the message. Any ideas how to fix it?



I'm afraid 7 minutes is not enough to complete GPS FW upgrade.

It usually takes 10-15 minutes.

And in your case upgrade has been interrupted in the middle.

Please open a ticket with the Support Team and they will try to restore GPS FW manually.

Thank you.

Ok I'll open a ticket. The GUI normally says it only takes up to 3 minutes I believe. You may want to change that message.