Hosting an NTP Server

Has anyone built their own NTP server for their network? Perhaps one that uses public servers as a reference (ie. If so, what have you used for software, hardware, etc.?



You bet.

Any current linux distribution will have NTP tools. Windows may be more of a challenge, but then I wouldn’t know. I’ve never tried to make any version of Windows an NTP server.
For more info, see:


That should get you started.

Here’s a couple of other resources: … NTP_Server

Thanks Guys, much appreciated. This will give me something to do when I’m not busy… :lol: haha


download and install opeansues 10.2 free (the best free linux if you ask me)
click on the clock in the bottom right then config this with config the NTP server opean NTP in your Firewall then the Lan IP of your opeansuse box is your NTP server its realy as easy as it sounds
i also am running 3 DNS servers off the same box
works awsome with my canopy 900Mhz system


I actually wrote a how to for the forum at DSLR…

Ok, as per my usual deal on configuring Linux things so that those here that do not understand:

Base system: Debian Sarge

After installation:

Set a static IP for your box:
Edit the file /etc/network/interfaces and tailor it appropriately for your system design.

I ran apt-get for the following packages:

Once those were finished I edited the /etc/ntp.conf file and uncommented out the second default NTP pool (just for now, later I will add servers that are closer) and pulled off “noquery” from the line:
restrict default kod notrap nomodify nopeer noquery

restart the service:
/etc/init.d/ntp-server restart

And run the line:
watch 'sh -c “ntpq -p -c as && echo && ntptrace”'

This lets you see what is going on with the NTP server. After a short while you should see the stratum on your local machine drop down below 16.

After things pan out (stratum drops) and I am satisfied with everything, I am going to put it behind the firewall that it goes behind, and re-install everything.

Linkage for everyone:

I actually have an NTP server that I set up on our network (using ntpd) and while everything else using it (servers, etc) will properly set itself to EDT, our APs are stuck with GMT. Any ideas how to fix this?

If I recall correctly, that’s the deal. The APs only operate in GMT. At least in 7.3.6. We’re still praying for a version of 8 with working NAT…