How to connect to unresponsive ePMP2000

Following a power cut an ePMP2000s is not working, (2 identical units have come back on). I have tried to reset via the power on/off sequence without success and also manually pushed the reset button from a shakey ladder, still no success. Pinging the device using its old static IP address and the default address both fail. The green power light is on and the orange light is on showing I think there is some ethernet activity. Any suggestions on the next step. A direct ethernet connection via the power supply does not connect using the default address. Now at a loss and any suggestions most welcome! Simon

Can you access the radio with

thanks for your quick repluy no luck either with that address

Have you tried replacing the cable ends?

No perhaps I should, very difficult access at top of ladder in freezing wind and frost, so hoping to avoid having to remove cable and remake ends. Will get some new cable and start again if necessary.

On pushing and holding the manual re-set button I was expecting the green power light and orange light to go out and the unit to re-start with factory settings but there was no change to any of the lights. Perhaps the reset button has failed or is there no change to the light status on re-setting ?

Have you bypassed or replaced the surge suppressor?

The unit was installed without a surge surpressor.