Ipv6 PD setup

I am using Mikrotik CCR for my core routes and network. For every CPE Router I am using the Cambium cnPilot 201 or 201p.
However, I cannot guarantee ipv6 on my network with this hardware. I need the configuration to setup the router to automatically start serving IP addresses from the Ipv6 PD pool that was given to the router.  I can manually setup the DHCPv6, but I cannot guarantee that the ipv6 prefix won't change the next time the router reboots and asks for a new prefix.

edit: the router should instead be acting as ICMPv6(stateless) for local machines. and is set in the ipv6 LAN page by default. 

Any help would be appreciated.

On another issue, i cannot get any ipv6 connectivity through PPPoE, but i believe that to be a mikrotik issue.

edit: the pppoe issue will be fixed in next firmware release. 

Hi Michael,

Please send network diagram to understand  your IPv6 deployment scenarios.  

Ipv6 connectivity through PPPoE is supported in latest image 4.3.3.



Thank you for quick reply.
The pppoe issue is less portent issue. I have core router ( mikrotik ccr) running PPPoE server set to delegate /64 prefixes from a /49 pool authenticated through radius. The cnpilot is directly connected to ccr with ethernet cable and acquires a prefix through PPPoE however no ipv6 connectivity is made between cnpilot and ccr. When using dhcpv6 there is no issue of connectivity. Again, I believe this to be mikrotik issue not cambium.

My biggest issue is next, if the cnpilot does receive a prefix, it does nothing with that prefix. I go to the ipv6 Lan tab, but there is no option to set the cnpilot to dhcp the network addresses using the prefix that was dynamically assigned. I can only get addresses assigned when I put everything in manually. How should the ipv6 Lan tab be set up to utilize the prefix that was delegated to the cnpilot? Additionally, how do I make the cnpilot automatically assign itself an ip from the same pool? Or should that be done from the core router? I mean, I should not need more than a prefix delegation to allow the router to connect to the ccr?

Hi Michael,

We are investigating on the PPPoE issue.

Below is the solution for prefix delegation issue,

My setup,

Dibbler (ipv6 Server)-----> R-Series---->LAN PC

Below are the steps to achieve your requirement,

*Enable "Prefix Delegation" on "Network->WAN" page

*Enable IPv6 on "Network->Ipv6 Advanced"

*Don't do any changes on "Network->IPv6 LAN" page, leave it default

After this your router WAN will get IPv6 address and IPv6 PD prefix from server (in your case ccr).

Your LAN side PC will get IPv6 address from the prefix delegated.

Attached screenshots

Thanks, that has gotten me closer. My router is now giving out dynamic IPs from the delegated prefix. However end to end ipv6 connectivity is still an issue. The issue is that the cambium router seems to not add a default route to the internet(2000::/3) to go through the core router/wan interface.

I've added a couple screen shots detailing the issue.

The First screen shot is my computer conected to the cambium router. First, pinging the cambium router, no issue, pinging the core router, no issue. Then when i try to ping the wan interface of the core router, the cambium router says no route to host. If I attempt to ping netflix(or any website) then still, cambium router says no route to host.
The second screen shot is me using a mikrotik hAP AC lite(a $40 router...) in the exact same configuration using PPPoE to obtain a prefix from the core router. You will notice instantly that end to end connectivity is apparent in pinging netflix.com. Next i did a traceroute to ipv6.google.com, showing that it first pings the mikrotik router, then the core router, then my provider's gateway(.....c002:1::1). This shows that my core router is correctly set up to delegate and route IPv6.

Sure. We will debug this issue. Please send current DUT  and Mikrotik router configuration details to this email id (niraj.mahapatra@cambiumnetworks.com).



For future readers, Cambium has said they will fix the issue in the next firmware release.

Do you know if they have solved this problem?
Michael I would like, if possible, to talk to you, we are an isp and I would like your advice, if you have already implemented ipv6 please

in the latest firmware ipv6 PD over pppoe automatically adds a default route through the wan interface

1 Like

We seem to be having the exact same issue but we are not using pppoe. Has anyone been able to get end to end IPv6 connectivity not using pppoe on R201 4. 3. 4?

I am having the same problem without pppoe in version 4.4.1

biggest issue i have with cnpilot is that the fd00 subnet is local site which means not global routed they need to fix it to allow dhcp-pd to the lan then all you need to do is set your prefix delegation to be always the same. which can be configured by radius or long lease time.

wan should be manually configured or automatically by EUI-64


Yes we are aware of this, and working to get this resolved. 



1 Like

Do we have a time frame on this? Been a few months. we're up to 4.5 firmware and I still can't seem to get PD on my LAN.

Could you get IPv6 PD working as per attached DOC . IPv6 end to end connectivity works with a workaround as mentioned in the doc . We are fixing this in 4.6 release 

Hi, is there any movement on this? The first post about this issue was nearly 2 years ago and we're stil without answers. 

Hi , 

 Query has been answered on the previous post . Please find the attached doc for ipv6 prefix delegation to work on R-Series routers  . This doc mentions a workaround for ipv6 + pd set up to get this working  . This issue  will be fixed  in 4.6 (where you won't need a workaround)

1 Like