LinkPlanner 5.5.0 won't start

I just found the v5.5.0 update and installed it. I’ve installed over the older version of v5.4.4. Program loads, or attempts to then shuts down. I can see the beginning of the GUI but not for long. No errors codes / boxes noted.

So I figured up via the Console and not errors there. I’ve done console mode for both version (I tried installing the v5.5.0 into it’s own directory just to be sure. There are unknown license errors in the v5.5.0 console. I’m guessing that is the problem?

I do not see a log file to review either. So not sure what I’m missing here. v5.4.4 works like a champ on my Windows 10 Machine.

What other info would you like to see?

v5.5.0 console output:

Let me know what else you may need to see.

1 Like

Here is the v5.4.4 console output

Hi Dean,

With v5.4.5 we started to build the Windows version of LINKPlanner on Windows 10. Previously it was built on Windows 7 to maintain backwards compatibility. Unfortunately this move has caused a problems for a few Windows 10 users.

If you see LINKPlanner crash in this way, you need to set the LINKPlanner exe to run in Windows 7 or 8 compatibility mode.

Unfortunately we are unable to reproduce the problem at the moment so we don’t have a permanent fix, but the work-around is simple enough.




Fair enough Andy. Thank you. I tried Windows 8 compatibility and that is working.

I have similar problem, am runing 5.5.0 now but the link planner starts normally but as soon i click on new project its starts loading and then fails (linkplanner windows disappears)

I tried running it with Win8 or Win7 compatibility mode but still same issue


Try the following to see if it helps:

  • Close LINKPlanner
  • Click Start → Run (Windows Key + R)
  • Enter “%APPDATA%\LINKPlanner” into the Open box and click OK
  • Select and delete the “modules” directory
  • Now navigate to “%HOMEPATH%.matplotlib” and select and delete “fontList.cache” and “fontList.json”

Try LINKPlanner again. If that still doesn’t work then your machine may have issues with the embedded Internet Explorer control. To disable this:

  • Click Start → Run (Windows Key + R)
  • Enter “cmd” in the Open box and click OK
  • Type the following in the console:

Those settings will disable the online map view and use a simple HTML viewer to render any HTML messages rather than the embedded Internet Explorer control. Hopefully the earlier fixes will work and this won’t be necessary though.



1 Like

Thanks Andy second part disabling the online map solved the issue

Hello after following this guides

Click Start → Run (Windows Key + R)
Enter “cmd” in the Open box and click OK
Type the following in the console:

I cannot see more Online MAP,
Please help to show also how to restore online MAP if you need to output NLOS via viewshed

Hi Julien,

When these environment variables are set LINKPlanner does not display the embedded IE window and it doesn’t display the online map.

There are several ways to delete environment variables. See How To Create, Edit, Clear and Delete Environment Variables Easily in Windows 10 ? for instructions on how to delete variables in the command line (solution 1) or in the environment variable user interface (solution 2). If you are unsure, then follow the steps in Solution 2.



Hello I have did all the command below but still not open the appl


So you have set the the LINKPlanner exe to run in Windows 7 compatibility mode and have the environment variables set to disable the map?

If you run “c:\Program Files\Cambium Networks\LINKPlanner\LinkPlannerConsole.exe” in a cmd window what do you see in the output? Some of the warnings are expected.



Compatibility mode for win 10 user running as win 8 worked. sept 2021

We’ve just released an updated version of 5.5.1 which seems to address this issue (thanks Ashutosh Vasudeva for your assistance with this).

Download the “Windows Installer (alternative install)” from Log In / Cambium Networks Support.

You may need to delete any environment variables that were set to disable the map view (LINK_PLANNER_HIDE_GMAP, LINK_PLANNER_SIMPLE_HTML). To delete the environment variables:

  1. Right-click on “This PC” and select Properties
  2. Click on “Advanced system settings”
  3. Click “Environment Variables…”
  4. Select the environment variables and click Delete as required before clicking OK



1 Like