LINKPlanner v4.6.3 running under Wine 2.0.3 in Ubuntu?

Hi there,

I'm wondering if anyone has managed to get this working? Below is the error I'm getting.

fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias 300, std (d/m/y): 5/11/2017, dlt (d/m/y): 12/03/2017
fixme:msvcrt:type_info_name_internal_method type_info_node parameter ignored
fixme:atl:AtlAxWinInit version 0300 semi-stub
fixme:ieframe:PersistStreamInit_InitNew (0x1beb40)
fixme:atl:OleClientSite_ShowObject (0x1b8410) - stub
fixme:ieframe:navigate_url Unsupported args (Flags 0x49ce2d8 {VT_I4: 0}; TargetFrameName 0x53f75f8 {VT_ERROR: 80020004})
fixme:atl:OleInPlaceFrame_EnableModeless (0x1b8410, 0) - stub
fixme:atl:OleInPlaceFrame_SetStatusText (0x1b8410, L"Start downloading about:blank") - stub
fixme:atl:OleInPlaceFrame_SetStatusText (0x1b8410, L"Downloading about:blank") - stub
fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0cb608, context 0x23d4528, init_notify 0, handle 0xf90e794): stub
fixme:imm:ImmGetDescriptionW (0xc090c09, (nil), 0): semi stub
fixme:imm:ImmGetDescriptionW (0xc090c09, 0x128452a0, 9): semi stub
fixme:imm:ImmGetOpenStatus (0x697a740): semi-stub
fixme:imm:ImmReleaseContext (0x10118, 0x697a740): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:ieframe:BrowserService_GetTravelLog 0x1d7678 0x32c8a8
fixme:ieframe:ClientSite_GetContainer (0x1bec0c)->(0x32c868)
fixme:mshtml:nsChannel_GetContentDisposition (0x6980c40)->(0x32c0a8)
fixme:mshtml:nsChannel_GetContentDispositionHeader (0x6980c40)->(0x32b7fc)
fixme:atl:OleInPlaceFrame_SetStatusText (0x1b8410, L"") - stub
fixme:atl:OleInPlaceFrame_EnableModeless (0x1b8410, 1) - stub
fixme:ieframe:ClientSite_GetContainer (0x1bec0c)->(0x32d648)
fixme:win:EnumDisplayDevicesW ((null),0,0x32ccd4,0x00000000), stub!

I haven't tried running it under Wine for a long time, but the error seems to indicate that it is related to the embedded Internet Explorer that we use for the Google Map view and the Getting Started panel (as well as a few other places). I tried searching for the errors that you were seeing and it took me to this page: In particular this comment -

"it looks like their app is using IE components to render the window -- and that's bad news since only very old IE versions will work in Wine."

We are aware of a few other users running under Wine, one of them may be able to share their experience, but it may not be possible to get the current release of LINKPlanner working under current versions of Wine.

1 Like

Thanks for the quick reply Andrew. If I come across any new info I'll post it in here.

1 Like