Not getting Sync from uGPS on PMP 320 AP

If using uGPS as a sync source for PMP320 on timing port then only selecting Sync Source as "uGPS" on Settings page is not enough, the option "Serial Type" must also be selected as "uGPS".

In AP goto Configuration-> General-> Settings and select Serial Type as "uGPS".