NTP wrong time

I’ve decided to mount an NTP server (linux) to provide clock and date sync to every Canopy on my network.

This NTP server is working perfect, i know this because i have 10 computers asociated to this server and the system clock works OK.

The problem is I configure Canopys to get time through NTP server and always shows me 4 more hours than the actual time.

In the screenshot can be seen the time of my PC (09:45) and the time of the Canopy device: 13:42. It happens with all the canopy devices i have tested.

Both (my PC and Canopy’s) are using the same NTP server to get time.

I thought my problem could be here in Chile i’m UCT -4 and Canopy maybe increases automatically 4 hours to work at UCT. If so, i don’t know how to fix it.

Has anyone the same problem?

maybe you could just set the clock in the ap’s and sm’s to match the servers cause they reset everytime you telnet into the units and do a reset.
cause i am not 100% sure but i think the timing has nothing to do with your sm,s and ap’s clock setting.


There is a lot of this devices on my network and i have the need of using them synchronized to a central NTP server, so using “manual” time configured on each Canopy is not what I need, but thanks anyway :slight_smile:

I have noticed this as well. I have confirmed that the APs take the NTP responce from my linux NTP server and somehow convert the time to UTC. I assume this is related to the lack of timezone setting in the APs.

I have not looked for a solution though, I just “live with it” – remembering that the Canopy equipment is using UTC time.

here they use GMT, even on the CMM micro the clock gets sync to GMT.

may be in later series they will get to get time zone settings.