On-Premises 2.4.2 Upgrade Failure

Just tried to install the 2.4.2 package upgrade to our on premises Maestro. Uploading the package seemed to work, and the system restarted. Attempting to access the cnMaestro URL gives a “Service Temporarily Unavailable” error. It helpfully suggests trying again later, but after 20m or so it is still not working.

Going to the shell, /var/log/syslog is full of:
cnmaestro-health trying to restart
Started cnMaestro Health Monitoring Service
cnmaestro-health.service: Main process exited, code=exited, status=1/FAILURE
Stopping cnmaestro-health-agent
start-stop-daemon: warning: failed to kill : No such process.
cnmaestro-health.service: Failed with result ‘exit-code’.

It’s running on a VMWare ESXi host, and has been running great for months. Is there anything I can do to diagnose/fix, or should I just install a new OVA and restore my backup?

Alright, so this turned out to be our fault. We’d apparently missed an OVA upgrade and the package applied to the old one - and broke it. Downloaded a fresh OVA, restored backup, had a bit of a fiasco with it not knowing about half the devices until they were freshly onboarded, and it is working again. EXCEPT - the CBRS page only shows one sector! The other sectors are listed just fine in the tree. They appear to be talking correctly to the SAS, because they are online with users. Go to the CBRS page in Maestro, and it only lists the one sector.

Is there any way to tell Maestro that the data in the SAS is accurate, and import it? I’ve got the spreadsheets for all of the sectors if I need to re-import, but hoping to avoid de-registering everything!

Could you please tell us from which OVA/package version you had upgraded to 2.4.2 package.

I updated the ticket. It was the final 2.4.1 release candidate; we hadn’t noticed that the next one came out and applied the package to the wrong OVA. Fortunately, we’re back up and running after extracting a fresh (our previous backup turned out to be stale) backup from the failed system via the CLI and applying it to the new one.

I’ll tag along here since the subject is about what I would use. I am running 2.4.1-r10 OVA and am trying to apply 2.4.2 package update to it. I am getting the following error:

Error: Unable to extract VMDK file from OVA: /srv/storage/tmp/cnmaestro-package.ova

/bin/tar: This does not look like a tar archive
/bin/tar: Skipping to next header
/bin/tar: Exiting with failure status due to previous errors
Unable to extract VMDK file from OVA: /srv/storage/tmp/cnmaestro-package.ova

I’ve re-uploaded and applied the 2.4.1-r10 OVA without issue. This is my first attempt at an upgrade with on-premises.

Hi Au Wireless – these error messages generally occur when the upgrade package is not downloaded completely. Please verify the SHA checksum to make sure it is correct before upgrading.

Keeps failing with Firefox but succeeds with Chrome. Huh.

Hi Au Wireless – if you normally use Firefox, you may want to try a hard reload, to make sure the browser is not caching older files. If it still has problems, please let us know the deployment (cloud, on-premises), the cnMaestro version, and the browser details (version, OS).