Port Forwarding not working?


I'm having some troubles with port forwarding on SM side.

SM has a static public IP address (79.2.168.***). 

Added (for example) this rule under Configuration -> Network -> Data Port Forwarding:

Protocol: TCP + UDP

Port Begin: 33656

Port End: 33656

Forwarding IP: (ePMP acts on NAT Mode)

Mapped Port: 33656

However, even if I assign on a test PC the static IP and check on online sites (like yougetsignal, canyouseeme) I always get that the port is not open, so connection refused. Why?

Note: as said the ePMP directly acts as a NAT device, ePMP and PC are connected to a router that acts just as an AP.

Nobody never faced this?

What is it that is running on 33656?  I see you're trying to forward both TCP + UDP, but do you know for sure which protocol this application is using?

Should be easy enough to test general port forwarding functionality, at least for TCP.  Fire up some known-to-work service (web server, telnet server, SSH server, etc.) on 33656 @ that IP, verify that you can connect to it from something else on the same LAN (e.g., "telnet 33656") and see if it connects.  Then try the same thing from the outside directed @ the ePMP's WAN IP.

If you know this app responds to TCP @ 33656 then I suppose it's just as easy to run the same test to the actul box you're having trouble with from the LAN, too.  If you can't "telnet 33656" from some other host and have a TCP socket open up, then you know the problem isn't with port forwarding, but something more fundamental than that with the application running on the box itself (if this is a PC, maybe there's a software firewall running on it?).

-- Nathan

Hi Nathan,

Thanks for your reply. The port 33656 isn't referring to anything particular, it was for example. However, I just tried with an effective example.

I hosted a FTP Server, running on a machine with local IP address, disabled any antivirus/firewall for this test. I'm able to access the FTP Server from any device behind the LAN, as suspected.

Then I added the following rule on ePMP:

Protocol TCP, port begin: 21, port end:21, IP address:, mapped port: 21

Saved settings, then tried to type on browser " ftp://(the external IP address) " to see if it was reachable from outside. And then, I received the access denied. Seems the ports remain blocked for no reason...

What version of the firmware are you running ?  We had a lot of various problems with port forwarding all the way up to ... I think 2.6.1  and maybe the first couple of v3.#  but since 3.4.1 I don't think we have had a problem.

Hello brubble1,
The version of ePMP is 3.4.1, so I guess it should be alright?

I looked at the radio that we use to have a lot of trouble with (port forwarding would just stop working) and it's running 3.4.1. To the best of my knowledge we haven't had a problem with it in several months.

I think a difference between ours and yours though is that even when we had trouble port forwarding worked most of the time whiel on yours it doesn't appear to be working at all so probably a different issue.

As for testing it at those websites,  does your test PC have those ports open and is something listening on them that would answer the sites ?     You may have said as much but I didn't go back and reread you post . I guess if you haven't already you need to test your test pc to those sights without the ePMP radio in the mix to make sure the problem isn't you PC.

 What happens if you turn off port forwarding and just turn on DMZ with the IP of your laptop as the DMZ IP ?  We did that to solve some port forwarding problems over the years. 

It also seems that I remember having UPnP IGD and/or NAT PMP  enabled caused problems with either port forwarding or DMZ ... been a few years though so I may be rememberign that problem wrong.

There is definitely a problem where port forwarding stops working that still exists in 3.5.1 (I'm not sure about 3.5.2, as I haven't tested that particular problem on the beta yet). I think that it happens when a PPPoE session gets dropped, and reconnects, but I haven't verified that it happens everytime, or if that's the only thing that causes it. Rebooting the SM always fixes it.

Hi all,

We have 2 known issues related to Port Forwarding functional.

1. Port Forwarding sometimes doesn't work with PPPoE enabled after SM was rebooted.

2. Port Forwarding sometimes doesn't work with VSA configuration received from RADIUS server after SM was rebooted.

Workaround: Change Port Forwarding rules order and save configuration.

We are trying to fix issue as soon as possible.

Thank you and sorry for inconveniences.

1 Like

I have a static white address and I cannot configure the DMZ. Also, port forwarding does not work either. Can you advise something other than installing a router? Force is configured as NAT.