power failure during upgrade - unit fails to boot up now

Hi guys,

I was upgrading epmp unit & the power disconnected. Now the unit does not come up. Ethernet led keeps blinking, & the port keeps flapping. I have tried ping'ng it with and but still not reachable. Is there any way to fix this?



Have you tried a TFTP recovery: http://community.cambiumnetworks.com/t5/ePMP-Troubleshooting/Recovery-of-flash-corrupted-ePMP-devices-caused-due-to-power/m-p/54712/highlight/true#M13

If that doesn't work, unfortunately the uboot is corrupted and the unit is not repairable. 




The problem is that interface keeps going up & down. I have tried assigning 192.168.1.x/24 and 169.254.1.x/24 ip on the host. But the int is not stable, ping fails, and there is no tftp req seen in traffic..

are there any options now? the unit should not get bricked that easily. don't you think.?

If the interface is going up and down, then the uboot is corrupted. The radio is a single flash bank device and, like any such device, there is a risk of flash corruption if power is interrupted during a flash write. In your case power was interrupted resulting in a uboot corruption and that’s why TFTP recovery is not possible. It’s not uncommon and we warn users right on the software upgrade page on the GUI.

1 Like