Prizm Install on CentOS 4.3 64bit [Closed]

GDay all,

I am trying to install Prizm 2.0 on CentOS 4.3 (64bit) and cant seem to get it to work. Im new to rpm based distros (Im a Gentoo user) but i followed the user guide step by step for both MySql and PostGreSQL installs but cant get anything to work. After each install I can go to the webserver via a browser but under the server information line it says Server Is Down in red. The Prizm proccess is running tho.
In the log file all I get each time i start the server is:

06/20/06 21:22:17 INFO SYSTEM Log Level Changed to : INFO
06/20/06 21:22:17 INFO SYSTEM System Log Severity Level: INFO
06/20/06 21:22:17 INFO SYSTEM Starting Prizm EMS Server…
06/20/06 21:22:17 INFO SYSTEM Build Version: 2.00.r1( 04.14.2006 13:38:07 )
06/20/06 21:22:17 INFO SYSTEM Java Version: 1.5.0_07
06/20/06 21:22:17 INFO SYSTEM Platform: amd64
06/20/06 21:22:17 INFO SYSTEM Operating System: Linux
06/20/06 21:22:17 INFO SYSTEM OS Version: 2.6.9-34.EL
06/20/06 21:22:17 INFO SYSTEM Installing Security Manager

Thats it no more info, it seems to stop after Installing Security Manager.

Java is setup.

Any ideas ??

Also when I try to connect thru the web interface i get a java error

java.rmi.NotBoundException: CanopyPrizm


Check /usr/local/Canopy/Prizm/logs files to see why the server is not starting. My guess is that you don’t have the License Manager (lmgrd) running or giving out the correct licensing.

(At least that was how I resolved that error!)

All I have in the log files is what I pasted above thats it it just stops there no error’s etc.

I tryed changing the LOG_SEVERITY_LEVEL in the startup script to DEBUG but it didnt make a difference.

All i get in the older logs (var/log/canopy/) are:
Wed Jun 21 16:39:15 WST 2006

= + = + = + = + = + = + = + = + = + = + =
- Started -

thats it its the same for lmgrd, prizm and prizmtomcat.

lmgrd is running:

[root@prizm1 canopy]# ps aux |grep lmgrd
nobody 3915 0.0 0.1 2164 1112 pts/1 S 16:35 0:00 /usr/local/Canopy/FLEXnet/lmgrd -c /usr/local/Canopy/FLEXnet/license_files
nobody 3916 0.0 0.1 2456 1400 ? Ss 16:35 0:00 motocnpy -T 10.0 3 -c /usr/local/Canopy/FLEXnet/license_files --lmgrd_start 449904bf
root 4093 0.0 0.0 51096 660 pts/1 R+ 16:44 0:00 grep lmgrd

I think its a liscence issue also because I have done everything else right, (I think :slight_smile: )

eth0 (which I think prizm looks for matches the mac addy in my liscence file so that should be ok.

any ideas how to make my logs show debug info?

OK after manny coffees and a few burbons I think i have found the problem. the script isnt setting any of the variables defined in the script, thus why I cant change the log settings etc.

Now a few more coffees and hopefully I will have it fixed.

Anyone else have a similar problem ? or think im on the right track


Fixed a few errors such as libs cannot be found but, now I have

Exception in thread “main” java.lang.UnsatisfiedLinkError: no Prizm in java.library.path

any ideas on that one? I thought LD_LIBRARY_PATH set java.library.path ?

Ok now im back to:

Exception in thread “main” java.lang.UnsatisfiedLinkError: /usr/local/Canopy/Prizm/bin/ /usr/local/Canopy/Prizm/bin/ cannot open shared object file: No such file or directory

but it IS defined in LD_LIBRARY_PATH and it does exist.

It just dosnt seem to load the libs required. Has anyone installed prizm on a 64bit OS yet ? Would that be a prob for lib locations etc?

OK I gave up on rpm based distros and went back to trusty old Gentoo.

Now I have a fully functioning Prizm 2.0 server running on Gentoo, I will post a howto next week as I remember seeing a few people trying to install Prizm on Gentoo before.

Working with the same issue right now.

Motorola’s only suggestion was to ensure that I had the Legacy Software Development packages installed from the distro CD, which I did, but still didn’t change any problems.

I called Moto tech support on this as well, and they told me that it is “usually solved by rolling the installation back to RH3.x” which isn’t going to happen.

Still working with Moto for some kind of resolution.

Motorola Tier 3 replies…

Currently, Prizm isn’t supported on a 64bit kernel. You will need to reload a the 32bit RedHat 4 version.

The requirement to have a 32bit operating system to run Prizm was never explicitly stated in the User Guide. This was an oversight on our part and I apologize for that. The documentation correction will be implemented in the next point release of Prizm. Prizm is slatted to support a 64bit architecture in version 3.0.

V8.0 is expected to be released in Q3. (I’m assuming 2006, but I should perhaps not be so brave…)

I asked after the fact when this incompatibility arose since we were running Centos 4.3 x86_64 with Prizm v1.x without any issues, but have so far received no answer.

I had the same problem a while ago, after upgrading from Prizm 1.1 to 2.0 running on CentOS 4.3. The difference is that no matter how hard I tried, Moto’s support wouldn’t really tell me much because I was running an unsupported version of Linux. The problem was exactly the same. Since I was running out of time, I decided to switch to a supported plataform (windows 2000). To my unsurprise, I had the exact same problem on Windows. Called back tech support and even when I was using a supported plattaform, they wouldn’t scalate my issue.
They suggested downgrading Java to a previous version. Didn’t help. Now it is fixed.
What I think it was, and this is from a Java-don’t-know-how standpoint, follows:

In Prizm’s 1.1 installation manual they instruct you to download the latest Connector/J from the Mysql website and the only thing they tell you is that you make sure the mysql-connector-etc.bin file is in the right path. That worked on Prizm 1.1
When upgrading to Prizm 2.0 and even when talking to tech support, they also ask you to make sure you have that file in the right path, which I did. But; at the time we installed Prizm 1.1, the zip file you get from the mysql website only had the Connector/J .bin file and nothing else.
The one I downloaded during the Prizm 2.0 upgrade, not only contains the connector/J .bin file, but a bunch of other files. As soon as I decompressed and added those aditional files, my prizm 2.0 started working like charm. This might sound stupid and obvious, but for those of us who don’t know much about programming, it is not. Nor the manual or tech support tell you this, they just ask you about the connector/J .bin file. I’m almost positive that this would have made it work on Centos as well.

PLEASE…do correct me if I’m wrong