Problem with BAM 1.1 software

Hi all,

I just purchased the Motorola Canopy 2.4GHz AP and SMs and BAM (1.1) software. I am having a problem with the BAM software when trying to log in from the GUI:

Unable to authenicate
Please check your user name and/or password
Error Message: DB Error: connect failed

I have also verified that the required packages are installed in Red Hat
9, namely,


I was able to login as Administrator (no password) and created additional users & passwords. However, when I tried to login as one of the user I created, it gave me the above error message saying that connect failed.

I checked mysql and verified that the users I created are in the mysql databse. I also noticed that the folder “04004SSE” in var’lib’mysql has no database files.

Do I need the APAS in order for it to work (I still haven’t received it yet)? Right now, I am just setting up the SM and this was the first SM I tried.

I was wondering if any one out there has any suggestion how I can create the database because the Canopy manual does not indicate how do to it.




It looks like the tables weren’t created during the install. Were you root when you performed the install?

During the install there is a script that automatically creates the database and tables. Look under var/log/canopy/ for a file sse_install.log which will say if the database was created.

Also, try the following:

mysql -u root (add a -p if you need to be prompted to a non-default password)

use 04004SSE;

select * from SS;

At the end of these 3 commands you should have some output. If not I would suggest trying to install BAM again.

The sse_install.log in the var/log/canopy/ directory indicates the database was created. The mysql commands failed at select * from SS; since there is nothing in the 04004SSE directory.

In any case, I uninstalled the BAM and re-installed it again. Now I can add the esn.

Thank you.