Problems after install


Trying to do an install of CNS Server on CentOS 6.6(x86_64).  Accepted all the defaults as far as postgres username/port.  When i try and login through http/https, no page loads.

Doing a #ps -ax shows something up with postgres i believe.

 2060 ?        Ss     0:04 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 2061 ?        S      0:00 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 2062 ?        S      0:00 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 2063 ?        S      0:00 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 2064 ?        S      0:00 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 2065 ?        S      0:00 /opt/cnsserver/stack/apache2/bin/httpd -f /opt/cnsserver/stack/apache2/conf/httpd.conf
 6248 ?        Ss     0:00 /usr/sbin/anacron -s
 6399 ?        S      0:00 pickup -l -t fifo -u
 6417 ?        S      0:00 /opt/cnsserver/stack/postgresql/bin/postgres -D /opt/cnsserver/stack/postgresql/data
 6419 ?        Ss     0:00 postgres: checkpointer process
 6420 ?        Ss     0:00 postgres: writer process
 6421 ?        Ss     0:00 postgres: wal writer process
 6422 ?        Ss     0:00 postgres: autovacuum launcher process
 6423 ?        Ss     0:00 postgres: stats collector process
 6462 pts/1    S      0:00 /bin/bash ./
 6470 pts/1    Sl     0:02 ../jre/bin/java -classpath ../conf:../libs/backend/log4j-1.2.16.jar:../libs/backend/snmp4j-2.2.3.jar:../libs/backend/postgresql-9
 6485 ?        Ss     0:00 postgres: postgres cnss idle
 6486 ?        Ss     0:00 postgres: postgres cnss idle
 6487 ?        Ss     0:00 postgres: postgres cnss idle
 6488 ?        Ss     0:00 postgres: postgres cnss idle
 6489 ?        Ss     0:00 postgres: postgres cnss idle
 6490 ?        Ss     0:00 postgres: postgres cnss idle
 6491 ?        Ss     0:00 postgres: postgres cnss idle
 6492 ?        Ss     0:00 postgres: postgres cnss idle
 6493 ?        Ss     0:00 postgres: postgres cnss idle
 6494 ?        Rs     0:00 postgres: postgres cnss BIND

 I've tried stopping/restarting all the services, rebooting...

When i try and stop or restart the lappstackPostgresSQL service i get:

[root@cnss logs]# /etc/init.d/lappstackPostgreSQL restart
waiting for server to shut down............................................................... failed
pg_ctl.bin: server does not shut down
HINT: The "-m fast" option immediately disconnects sessions rather than
waiting for session-initiated disconnection.
/opt/cnsserver/stack/postgresql/scripts/ : postgresql could not be stopped
/opt/cnsserver/stack/postgresql/scripts/ : postgresql  (pid 1966) already running

So i try a killall postgres &&  /etc/init.d/lappstackPostgreSQL start
I get:

waiting for server to start.... done
server started
/opt/cnsserver/stack/postgresql/scripts/ : postgresql  started at port 5432

 but still the same (idle) output from #ps ax

Digging around through the /opt/cnsserver/logs dir all logs are emtpy except utils.log is filled with messages such as:

2014-12-15 08:58:14,836 ERROR ConnectionPool.validateConnection(): Connection to database lost.  Attempting to reconnect.
2014-12-15 08:58:14,842 ERROR ConnectionPool.openConnectionToDatabase(): Could not connect to the database: org.postgresql.util.PSQLException: Connection re
fused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
java.sql.DriverManager.getConnection(Unknown Source)
java.sql.DriverManager.getConnection(Unknown Source)
2014-12-15 08:58:14,843 ERROR ConnectionPool.getConnection(): Unable to recover lost database connection.  Shutting down server.

Has anyone experienced this or know what direction I should go?



Hi Justin,

Something is preventing CNS from connecting to the PostgreSQL server.  Is a local firewall running?  Has it been opened up on the ports listed in the quickstart guide, specifically 5432?

When you attempt to log in, do you get an error?



Someone on the AFMUG list helped me solve this.

It was firewall related.  The default iptables rules that were included in the CentOS 6.6 install needed to be flushed. 

#iptables -F



Good night I have a centos 6.9 and download the latest version of cnss for 64 bits, but I can not do the installation. this is the file that you download, someone can guide me how to do the Installation by Console. Thank you so much.

Would you please help me steps with command how to instal in centos7 by command line.

Thanks in advance.