Problems with Linksys routers????

Since last week I’ve been getting a lot of phone calls with customers using Linksys routers that began getting limited or no connectivity errors and some that get no errors and can’t browse at all. They reboot the router and it works for a few minutes then nothing at all.
We have made no changes to any of our equipment, and the only people that we are getting calls from are linksys users…anyone have any suggestions or ideas…please?

Before I learned canopy, I was a customer. I switched from using a switch to a linksys router. I plug’d the canopy into the WAN port, even though im sure they had NAT enabled. If I was smart, I would have plugged into a numbered port and had DHCP and NAT disabled on the router. Now that I think about it, I was using a PPPOE? connection, which I know little about. I always had to reset the router though. :roll:

If they reset the power does the connection start working?

My experience has been this is usually related to virus activity causing the memory buffers to fill up on the router.

Usually rebooting the router works, but I’ve been noticing lots of wireless sides giving the message limited or no connectivity and the only way to get rid of the message is to assign an ip manually. Have you ever seen a router quit handing out addresses only on the wireless side?


How long were these installed before they started having problems?

I think I would try flashing the firmware. There may be some traffic on your network that is buggering up the routers. Make sure you disconnect the radio from the WAN port before flashing the firmware.

We have also had this trouble, the last couple of months. we started putting the dns in all compters on a router. Shouldn’t haft to do that but it did cut out all the service calls.

2 months ago had a customer who was terminating our connection SM NAT/DHCP enabled into a linksys wireless accesspoint.

The accespoint started giving limited no connectivity for about 2 weeks, reboot of the SM or accesspoint would fix the problem, replaced the SM but no look. Customer site had 50 wireless laptops/printers/PC’s.

Then the acccess point died, we replaced it with an SMI wireless access point, major limited connect issues, reboot would fix it for a couple of hours. We thought customer was overloading the unit, we replaced it with a D-Link access point same thing, worked slightly better.

Eventually we intalled a wired network for the customer, no problems since.

I have used all different hardware and firmware versions of the 802.11b + 4-port Switch Linksys router over the span of the last three years. I have personally concluded that since Linksys was acquired by Cisco, that the quality of the product has degraded.

The absolute most reliable hardware version of this particular model is hardware version 3/4, which is the bulkier looking device with three LED’s per switch port.

The most trouble-some problems I have noticed over the years are the WAN interface and the WLAN interface tend to lock up. Yes, a simple reboot of the router fixes this, but it starts to become a pain.

I bought myself a Cisco 1605R off E-Bay about a year ago just to toy around and learn the Cisco CLI. It cost around $150.00, but it has been extremely reliable.

I have yet to find a SOHO router that I would actually call “reliable”.

We started out with Linksys and even had the standalone switches lock up. I agree when they got bought out and if walmart sells it it has to be cheap. The radios on the belkins didn’t last long. I had a netgear at home for a couple of years with no problems. We ended up using DLink and have had good luck with them. I know the post under this one is about the same problem but we havn’t seen it. We install a DI604 in all customer installs included in the install price. If they want a 802.11 we just charge the diff. We probably have 3 or 4 hundred out with good success. I have seen a few units bad, but they have all been 604’s not wireless. The biggest issue i see is if the wan port is set to dhcp client and the connection between it and the dhcp server is down or their is a power failure or anything sometimes the units will dump the old address and ask for a new one and sometimes they wont. When they dont they have to be power cycled.

After a couple of years the netgear still works fine but I have replaced it just to try something new. The first one is a DI-784 802.11a and g. Noproblems their for about 6 months. But I just had to have the new DGL-4300 Gaming router after reading the reviews on some game sites. The funny thing is I don’t play online games I just liked it for the High power wireless, Gigabit lan ports, High performance CPU and the main reason was the priority traffic routing capabilities. It,s been hucked up to the sm for about a month without any lockups. It is the heaviest of any i have tried, and i have tried most. I am tempted to open it just to see what all the weight is.