Problems with SNMP wiht Canopy (NMS)

I am new with Canopy equipment. I have configure a CMMicro and I have some problems with SNMP communications between the Micro and my NMS.
I have tried with the community string by default (Canopy) unsuccesfully I put a sniffer and I see no response from de CMM), and I have tried with other communities string as well, and I also test it with the SNMP Accesing Subnet configured.
If I configure an SNMP traps IP destination I get the folloging error when ever I try to poll (snmp-get) the CMMicro:

This is my request:
Simple Network Management Protocol
Version: 1 (0)
Community: Canopy
PDU type: GET (0)
Request Id: 0x0172d24c
Error Status: NO ERROR (0)
Error Index: 0
Object identifier 1: (SNMPv2-MIB::sysName.0)
Value: NULL

And I get this response:
Simple Network Management Protocol
Version: 2C (1)
Community: public
PDU type: TRAP-V2 (7)
Request Id: 0x54d1fae0
Error Status: NO ERROR (0)
Error Index: 0
Object identifier 1: (SNMPv2-MIB::sysUpTime.0)
Value: Timeticks: (51900) 0:08:39.00
Object identifier 2: (SNMPv2-MIB::snmpTrapOID.0)
Value: OID: SNMPv2-MIB::authenticationFailure
Object identifier 3: (SNMPv2-MIB::snmpTrapEnterprise.0)
Value: OID: SNMPv2-SMI::enterprises.

I am using WhatsUp Professional 2005 SP1a (I have run the scripts with
the Canopy MIBS that I have downloaded from Motorola web page to integrate Motorola MIBs into the system).
This systems is already working with others vendor equipment like Cisco.

I need help. Any ideas?
Thanks in advance.

Hello Community:
My answer was just there. Tha application was using snmpv1 for queries,
and it seems that Canopy only support snmpv2 (as stated on the trap packet), so I must upgrade my NMS to a new version.
Thanks anyway.