Programming multiple SM

Has anyone found a way to program multiple sm's at a time? I tried VIA forwarding through a Mikrotik, and it worked about 9 radios before ARP starting screwing everything up.

Updating and programming one at a time just takes to long

1 Like

How did you try using a MikroTik Router?

Maybe we can found a good way to do it :-D

/ip address
add address=192.168.88.12/24 interface=ether1 network=192.168.88.0
add address=192.168.88.13/24 interface=ether1 network=192.168.88.0
add address=192.168.88.14/24 interface=ether1 network=192.168.88.0
add address=192.168.88.22/24 interface=ether1 network=192.168.88.0
add address=192.168.88.23/24 interface=ether1 network=192.168.88.0
add address=192.168.88.24/24 interface=ether1 network=192.168.88.0
add address=192.168.0.10/24 interface=ether2 network=192.168.0.0
add address=192.168.0.10/24 interface=ether3 network=192.168.0.0
add address=192.168.0.10/24 interface=ether4 network=192.168.0.0
add address=192.168.10.10/24 interface=ether2 network=192.168.10.0
add address=192.168.10.10/24 interface=ether3 network=192.168.10.0
add address=192.168.10.10/24 interface=ether4 network=192.168.10.0
add address=192.168.88.100/24 interface=ether1 network=192.168.88.0
/ip firewall mangle
add action=mark-connection chain=prerouting dst-address=192.168.88.12 new-connection-mark=port2
add action=mark-routing chain=prerouting connection-mark=port2 new-routing-mark=port2 passthrough=no
add action=mark-connection chain=prerouting dst-address=192.168.88.13 new-connection-mark=port3
add action=mark-routing chain=prerouting connection-mark=port3 new-routing-mark=port3 passthrough=no
add action=mark-connection chain=prerouting dst-address=192.168.88.14 new-connection-mark=port4
add action=mark-routing chain=prerouting connection-mark=port4 new-routing-mark=port4 passthrough=no
add action=mark-connection chain=prerouting dst-address=192.168.88.22 new-connection-mark=port2
add action=mark-routing chain=prerouting connection-mark=port2 new-routing-mark=port2 passthrough=no
add action=mark-connection chain=prerouting dst-address=192.168.88.23 new-connection-mark=port3
add action=mark-routing chain=prerouting connection-mark=port3 new-routing-mark=port3 passthrough=no
add action=mark-connection chain=prerouting dst-address=192.168.88.24 new-connection-mark=port4
add action=mark-routing chain=prerouting connection-mark=port4 new-routing-mark=port4 passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2
add action=masquerade chain=srcnat out-interface=ether3
add action=masquerade chain=srcnat out-interface=ether4
add action=dst-nat chain=dstnat dst-address=192.168.88.12 dst-port=80 protocol=tcp to-addresses=192.168.0.2
add action=dst-nat chain=dstnat dst-address=192.168.88.13 dst-port=80 protocol=tcp to-addresses=192.168.0.2
add action=dst-nat chain=dstnat dst-address=192.168.88.14 dst-port=80 protocol=tcp to-addresses=192.168.0.2
add action=dst-nat chain=dstnat dst-address=192.168.88.22 dst-port=80 protocol=tcp to-addresses=192.168.10.1
add action=dst-nat chain=dstnat dst-address=192.168.88.23 dst-port=80 protocol=tcp to-addresses=192.168.10.1
add action=dst-nat chain=dstnat dst-address=192.168.88.24 dst-port=80 protocol=tcp to-addresses=192.168.10.1
/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=ether2 routing-mark=port2
add distance=1 dst-address=192.168.10.0/24 gateway=ether2 routing-mark=port2
add distance=1 dst-address=192.168.0.0/24 gateway=ether3 routing-mark=port3
add distance=1 dst-address=192.168.10.0/24 gateway=ether3 routing-mark=port3
add distance=1 dst-address=192.168.0.0/24 gateway=ether4 routing-mark=port4
add distance=1 dst-address=192.168.10.0/24 gateway=ether4 routing-mark=port4

Running off a default config. I am having issues with the ARP at times, where randomly one will pull to another port

6.35 changelog from RouterOS:

*) arp - apply Linux Kernel patch to stop RouterOS from randomly exhibiting misplaced ARPs;

Maybe it solves your issue :)

Anyway, I can't understand how you use your MikroTik router to programming multiple SM. Do you use your router as a sort of "intelligent switch" to connect to multiple SM without changing the IP on your computer?

That might actually fix it! 

Basically,  running default mikrotik ip, so pull deep WiFi.  Ether1  (wan) static incase you have to plug in. 

Ether2 redirects  0.2 to 88.12, and 10.1 to 88.22

Ether3 0.2 to 88.13, 10.1 to 88.23

And so forth 

Was h a issue with arp letting port 3 open in 2's ips randomly,  and vice versa with other ports 

turn an AP on with the default settings. use a 24v POE switch to power up 20 40 60 how ever many you want,  (DISABLE ALL OF THE ETHERNET PORTS OR THIS WILL MESSUP BADLY)

let them all register to the default config AP.    (it can be any epmp device, doesn't need t be a sync AP)

make sure your APC isn't set to loud and your AP isn't set to loud, CPEs hearing your AP at -10 db isn't good for them.

use CNS to discver all of these connected CPEs (they all will have a unique IP since its the radio side) 

bulk update them, bulk inport a config.

change your AP to match the config used in the field, make sure all of your CPEs lock as expected.

enjoy packing up dozens of radios and go to lunch early.

1 Like

That would probably work if we didnt set a static IP on the radios, and use 1 generic config per radio (2.4 or 5) then change IP in the radio


@Skullzaflare wrote:

That would probably work if we didnt set a static IP on the radios, and use 1 generic config per radio (2.4 or 5) then change IP in the radio


we use the same file for all of them so we can batch out quickly.  

using the mac address on the radio  (the default name)  we let the host of the radio update the NS record in our DNS via DHCP so we reach the CPE via epmp1000_abc123.cpe  and were in. no need to custom anything else in the radio.  the installer tells helpdesk what radio mac is, they open up ealign and help the installer aim so he doesn't have to carry an laptop around.    once they've hit the target for signal the generic auth info is removed and the customers correct info is put in, label and then radius does the rest.   

the generic auth rate limits to 100k down and 10 meg up so its good for us to tune, and obvious to the install something isn't right if help desk didn't do their job.

eventually, I'll try and get it do the DATA vlan just isn't assigned with the generic auth so it flat wont work for anything last aligning.

2 Likes

We do not have enough man power in office to handle both business lines with support and sales. As well as helping the field install.

We set the IP and record everything, so they only call if they need something


@Skullzaflare wrote:

We do not have enough man power in office to handle both business lines with support and sales. As well as helping the field install.

We set the IP and record everything, so they only call if they need something


if down the road you need help with the phones for support and sales, the call center we use is great, I'd recommend them to everyone, plus customers love round the clock support!    they charge us 800$ for 300 calls a month, turns out to be far less expensive for more bodies, atleast for us.

send me a PM if you'd like thier info. 

1 Like