"Proxy Arp" enabled causing issues w/ devices getting IP from DHCP on Bose, Amazon Dot, SmartTV, etc

Hey everyone, just wanted to post this in here after doing some troubleshooting.

I am deploying 50 e400s and as a test, I have been running 3 at my house to put them through the ringer. Overall they are great, but I can across a unique issue:

When connecting devices such as my Bose SoundTouch 10 speakers, Amazon Echo Dot, SmartTVs, and simple devices, when I have Proxy Arp enabled under "Advanced Settings", my devices are unable to receive an IP address from my DHCP server in a timely manner, or in the case of the Bose equipment, at all.

I've tried changing a number of other items and narrowed it down to this over the last 2 weeks.

I don't know why it's happening, but this fixed it for me. 

Running Firmware 3.2.1-r6 on AP (e400)
SNR is 42 dB, RSSI -64 dBm reporting on AP -> Client

Screenshot of all my "Advanced Settings" attached.


thank you for sharing this info, we'll check this out.

Could you please tell us what DHCP server this is, might help in recreating it in our lab. Also, how are the three APs connected, are they meshing among themselves or going into different ports on a single switch/router, where the DHCP server is also connected?

We also have this issue.
Problems connecting Google Chromecast to E400 when Proxy ARP is enabled.
Latest problem was in a network with Windows Server 2012 R2 as DHCP server, no mesh. AP's and DHCP on same L2 subnet.

Hi ,What did u do to make it work ,we have the same issue with chromecast