R195W DHCP Client list vs LAN Host

I’m logged into a R195W that was installed a couple months ago at our vacation rental. Status > LAN Host shows the 4 devices I know to be connected to the router. Network > LAN > DHCP Client List however shows 36 devices. I believe these to be all the different devices that connected to the router since installation. The 4 LAN Host devices show varying expiration times as expected. The other 32 that are not connected all show 11:50:01 for expiration. I’ve rebooted the router a couple of times, but the DHCP Client List never deletes these old, obsolete entries. Is this Client List just going to keep growing until all the DHCP available addresses are used up?

Router software is 4.7.5-R2

I had experienced something similar this last summer with a R195. It started after a really noisy power outage that bounced the power on an off a couple of times. This was at a business and they started having trouble getting users logged into the WIFI. The log was saying no IP available. I thought the unit got fried to I copied the config to a new unit and it was still doing the same thing. After I did a factory reset and started over it worked just fine. I had the same DHCP client list showing up after a reboot. Try the factory reset and then put your config back in from scratch.

I opened a ticket the day after posting this. They asked me to factory-reset, but I knew that would clear the client list without identifying the problem, so I didn’t. They asked me to update to the latest firmware (4.8), which I did. The DHCP client list was still the same. They then asked me to back down to the “recommended” firmware (4.7.1). After doing this, I saw that the client list was purged of the old entries. I connected a couple of devices to the router and waited until their DHCP lease time expired and confirmed that they properly dropped out of the client list.

Yesterday, I upgraded back to the original 4.7.5 firmware and added/removed a device. This morning, I saw that the device had dropped off the client list, as it’s lease time had expired. I’ll probably go ahead and update firmware to 4.8 and see if the problem stays away.

Oh, I should mention that I reproduced this problem on another R195W router with a similar configuration on the same firmware.