Recovering a cnWave60GHz device – Forgotten IP address / Forgotten password / Factory Reset

Recovering a cnWave60GHz device – Forgotten IP address / Forgotten password / Factory Reset

For situations with cnWave60GHz platforms when connectivity has been lost and so they cannot be managed, there is a Recovery Mode available that can restore control.

Recovery Mode requires a direct connection to the unit; only the wired/fibre connections are available for recovery.


A portable device (e.g. a laptop) is required to run a web browser to connect to the Recovery Web-GUI. Permission on this device needs to be at the admin level, it may be required to change/add an IP address. For the remainder of the procedure it is assumed that the device is a laptop.

A software upgrade (.img) file for the case where a unit is failing to boot to operational mode.

Procedure for entry to Recovery Mode:

  1. Form an Ethernet connection to the unit. This may be via a switch.
  2. While in Recovery Mode, the unit will be at, the laptop should be configured to an appropriate IP address, e.g. ( the remainder of the procedure will assume that the laptop is at ).
  3. If the unit is powered off, turn it on and wait (say) 30 seconds. If it is on, skip to next.
  4. Power off the unit briefly – i.e. turn it off and then back on again within 5 seconds.
  5. If the LEDs of the main Ethernet port can be observed, wait for the 2 LEDs to light red. If not, wait approx 10 seconds from power-on. This is the time taken to boot to Recovery Mode.
  6. In a web browser on the laptop, browse to
    NOTE : This step may take several attempts; while in Recovery Mode, the unit will look at each interface in turn for a connecting browser. If the laptop makes the request for the webpage while the interface is inactive (because another is in focus instead), the request will fail. The solution is to retry at the browser if the page (below) does not begin to display in the few seconds after the request is made.
    NOTE ALSO: Web browsers remember if a web server uses https and if will override a request to go to http at the same IP address. Since the Recovery page uses http, if the browser being used for recovery has ever successfully navigated to (e.g. the main Web GUI of the unit being recovered), then the browsing history should be deleted before attempting recovery. This will allowing the browser to connect directly to the http server.
    SUGGESTION : make a bookmark of the link above for ease of entry.
    The main Recovery Mode webpage looks like:

    Figure 1: Recovery Mode Main webpage
  7. If there is no contact with a web browser, Recovery Mode will exit after 1 minute and will continue to a normal boot. Hence if Recovery Mode is desired but the webpage was not successfully requested and served, repeat the procedure from step 4.
  8. If a webpage is served from Recovery Mode, the user has 60 seconds to compete the recovery activities.
    NOTE : Refreshing the webpage will restart the countdown timer.

Recovery Mode Features:

NOTE : Since cnWave60GHz V3000s run the same Recovery Mode software as V5000s, references to “v5000” from a V3000 while in Recovery Mode is normal and should not be considered a problem. See the “Device Identification” section below for the definitive means of identifying a unit.

With reference to Figure 1:


The top-left corner of the webpage maintains a countdown to the time when a normal boot will be triggered if no more action is taken.
NOTE : Refreshing the webpage will restart the countdown timer.

Device Identification:

The top-middle of the webpage displays the MAC address of the connected port of the unit being recovered. It is important to ensure that this is the expected unit. For confirmation, the MAC address is derived from the ESN of the unit which is printed on the label of the unit.

NOTE : While the main port will match the printed ESN, the Aux and SFP ports are at offsets of +0xF000 (hex) and +0x1E000 (2 x 0xF000) (hex) respectively.

Boot Type Selection:

Boot – Recovery Safe Boot:

Clicking this button will cause an immediate reboot to “Safe Boot”. This will boot the unit to the main operating system but with IP address This will allow access to the main Web-GUI of the unit to correct any misconfiguration that has occurred. For example, a Factory Reset can then be triggered. Once the main operating system has finished booting (single green LED on main Ethernet port), on the Laptop browse to Use “admin” as the username to log in, the password field is ignored in Recovery Mode “Safe Boot”.
Please Note: “Safe Boot” should not be used in conjunction with any other options in Recovery Mode. The image-handling options further down will take precedent over this

Boot – Normal:

Triggers an immediate, normal boot. Removes the need to wait for the countdown to expire. If the user is finished in Recovery Mode (or has entered it by mistake), this provides a means of exiting immediately.

TFTP load and program image:

In the event that the desired software load (.img file) is not programmed onto the unit (or it has become corrupt and will not boot cleanly), the desired .img file can be uploaded to the unit via the TFTP protocol.
TFTP Server IP: When in Recovery Mode, this is most likely to be the laptop, but can be any other machine that is connected via Ethernet at the time and has a IP in the network. This IP address must be set to that of the TFTP Server ( for the Laptop).

TFTP filename: The name of the desired file (relative to the root directory of the TFTP server service). The value in this field is limited in length to 64 characters.

Upgrade-TFTP: Once the IP address and the filename have been entered, the upgrade (over TFTP) is triggered by clicking this button.

HTTP load and program image:

In the event that the desired software load (.img file) is not programmed onto the unit (or it has become corrupt and will not boot cleanly), the desired .img file can be uploaded to the unit via the HTTP protocol.

HTTP filename: If the desired software load .img file is on the Laptop, the user can browse to the .img file, to select it.

Upload and Program: Once the .img file has been selected, the upgrade (over HTTP) is triggered by clicking this button.

The unit should then remain powered while upgrading. The software-upgrade process normally takes 5-6 minutes, therefore 10 minutes should be allowed in order to include a safety margin before attempting to get to the Recovery Mode again

Device Information:

Software Version: Displays the platform and the version string of the current SW image
IP: Current IP address (fixed in Recovery Mode)
Netmask: Current Network mask(fixed in Recovery Mode)
Gateway: Current IP gateway address (fixed in Recovery Mode)

Backup Recovery:

This section provides a list of software images currently available on the unit. The numbers of the buttons do not imply any order and is simply a means of identifying the buttons. If the Software Version in the “Device Information” section does not show the desired software version, but the desired software version is available in this list, the desired software version can be selected by clicking the corresponding button.

If the SW version is changed, the unit should then remain powered while upgrading. The software-upgrade process normally takes 5-6 minutes, therefore 10 minutes should be allowed in order to include a safety margin before attempting to get to the Recovery Mode again


A post was split to a new topic: V5000 stopped communicating after disabling on-board E2E

On the ‘Recovery Safe Boot’ Selection… After performing this step, is the the main OS accessible on the PSU interface? I’ve only been able to browse to the main OS, after performing the recovery steps on a deployed v5000, via the AUX interface. The v5000 was setup back-to-back using the PSU interface of the relay-port.

The v5000 in question is running v1.1.

If the PSU unit was configured for back-to-back (Relay port), after pressing recovery Safe boot, GUI will not be accessible. The reason is, this relay port will not be part of bridge.

We agree that its better for the GUI to come up in this scenario especially if the relay port was a mis- configuration.

We plan to make changes in the next release, such that recovery mode will ignore replay port configuration. So, GUI will come up on the PSU port in the scenario you described.

I have a V3000 that I am trying to reset to factory. I get to the recovery page fine, however, regardless of what I do, clicking the Recovery Safe Boot, does not boot with the default address
Can’t ping it after the reboot nor get it into the interface.
Tried with version 1.1 as well as 1.0

Hi Martin,

There are several possibilities here, so I’ll list off some options (if for no other reason than for future readers)

If you already know the IP and credentials, using recovery is not required and factory reset can be done directly from the GUI. I assume you don’t know one or both of these

Once booted to safe-mode, if possible, try each Ethernet port for One of the other ports may be connected to the default IP even if the one you are trying is not. This can include using an SFP that was present when the V3000 booted

Note that the recovery page uses http while main web GUI uses https. Make sure the browser is trying https after booting to safe-mode

If none of the above works and assuming an Ethernet link has negotiated to one of the ports, more technical options are:

  • ping the port with a IPv6 multicast ping “ping6 ff02::1” (this needs an interface added that depends on the OS/machine you are using) while directly connected to the V3000 port

    The response to the ping will give a link-local IPv6 address.

  • Most browsers don’t allow a https connection to a link-local address, but if yours does, you can log in and perform the factory reset.

  • More likely, you’ll need to ssh to the CLI “ssh admin@<link local address + interface>” (safe-mode will default the password)

  • run “service show ifconfig” to see the IP configuration currently in place.

At this point, you may be able to work out what is mismatched with your laptop, but if not you can send me the output and I can take a look. You can email me direct at bacuffe1 -at- cambiumnetworks -dot- com



Hi, I am experiencing a similar problem here. On a brand new unit we changed the IP address and then lost connection to the GUI. We have checked the IP address is correct (and screenshot) before applying so we know it is correct. We then tried the reset procedure (via the PSU ethernet and SFP) and can access on booting up, but when we select default boot mode and the unit boots up, we can no longer access the GUI or ping We have tried the link local address issue - but this does not work (indeed we see the router on the SFP going via the ethernet PSU). We do not have a cable up the tower to the Aux port. We are happy to try any suggestions possible to help us get access back to the unit. We have tried updating the software and tried booting the different versions in the recovery boot mode - all loose connection after initial boot recovery screen selection.

Hi arobo,
Changing SW on the recovery web GUI (either with the Backup Recovery buttons or by supplying a brand new image file) is the same as doing a SW upgrade using the E2E-controller or the main node-UI; this means that the units should be left for 5-6 mins before attempting any other interaction (especially power-cycles). I will edit the main article above to reflect this. My first suggestion now is to boot the unit to the recovery page, check that the current SW version is the latest one available on the unit, if it is not, choose the latest version from the list available at the bottom of the page. Then choose normal boot and leave the unit undisturbed, and powered for at least 10 minutes. The unit should then be running that latest load and be booted to the main system. You may then be able to access the unit on the new IP that you configured.
If not, perform a short power cycle again, but this time only choose the safe boot option. wait a minute for the system to boot and then you should have access to (over the main (PSU Ethernet) port)
Question: could there configuration on the E2E-controller that is overriding the IP address you have set? If so, it should be possible to configure the unit from the controller and save you having to reset it

1 Like


Apologies for the confusion - this was over a period of a few days. To explain -

  1. Brand new unit installed with power to PSU and SFP interface to router. Logged in to using PSU port and changed IP address and apply. Lose GUI and ping to as expected.

  2. Allowed around 5-10minutes to log in to new ip address by both SFP or PSU port - no success.

  3. Reboot into recovery - no issues, choose recovery mode. Once recovery screen states going into recovery loose ping and access to

  4. This happens after several attempts over a few hours.

  5. Try uploading new software via recovery http. Loads ok. Reboots, left overnight.

  6. Try again both by SFP and PSU port - no access either on known ip address. Try recovery, same issue, no access via

  7. e2econtroller not connected. Tried also removing the SFP interface from the router (PSU interface not connected). Tried reboot procedure again - still no success.

  8. Next day - tried again updating software image - left for 1/2 day. Still no access.

9 Later in day - came back to it, tried to reboot again and select different images - still no access on or on programmed IP address.

This was a brand new unit - all that was done was logged in, changed ip address in settings, no vlan, no onboarding occured.

Hi arobo,
I’d like to try to understand what is happening here. Can you email me at
bacuffe1 -at- cambiumnetworks -dot- com
with a view to doing a desktop-share and a walk-through of connecting to the unit?


Yes - happy to help :slight_smile: Can set up a login for you to look at it

I am having the same issue as Arobo. What was the fix?

Hi David,
This is an old topic but I think it ended up that we could not resolve the problem remotely and replaced the unit.

Since then there have been updates to the Recovery mechanism to help prevent the need for same again. We have added the option to factory reset a unit from Recovery

For your issue:
Can you say what model unit you have and what SW it is running as far as you know
Are you in a position to view the LEDs of the main port of the unit?
Are you able to reach the Recovery webpage as per the instructions above ? - noting especially the problem with web browsers where they prefer HTTPS for IP addresses where they have used that before.