removing a AP failed

We had an AP fail, we replaced it the next day logged into cnmaestro and both the new and old one are their all sm's seem to be showing under the new ap.... but whenever i try to remove the old offline AP450 i get

Device (MAC: 0a:00:3e:xx:xx:xx) deletion failed. Child devices need to be deleted first.
how can i fix this, hell i upgraded from 1.3.x to 1.5.1 and the device is still their and wont let me erase it.


I just want to confirm, if you expand the old AP in cnMaestro's tree, I believe there are NO SMs currently displayed, correct?  


Yep offline and shows no sm under it in the am tab and in tree the drop downs empty


Do you have any SM which is continued to be in offline state prior and after upgrade?




Based on the details you provided in the original post on this thread, how many SMs are truly registered to the AP (i.e. from the AP's user interface)?  In cnMaestro, how many SMs does cnMaestro think are registered? 

Does it match?  Is their an SM missing from the "new AP" in cnMaestro ?  If so, can you please access that SM's user interface, capture the device syslog file and email it to me (  After that, de-registering that SM may resolve the problem for you (hopefully). 


Well in an odd turn of events, it let me remove it, not sure what changed, i removed all the disconnected sm's for like the 10th time and this time it just let me erase it. So problem is resolved but not sure what solved it exactly as i had tried removing the offline SM's before and it didn't fix the issue, the last time it did so :S

It's really odd it complained about "removing sm's first" but in the drop down it had no SMs in the list.