I am using Rodopi to connect to Prizm. Over the last month I have been going back and forth with Rodopi on the server not communicating with Prizm. They finally did a reinstall and I am now getting the following errors. It appears that Rodopi is attempting to connect to our Prizm server but is kicking back the below message. From the looks of it I think the problem now lies with Prizm. Specifically no accounts/equipment setup in the configuration. If that is the case then I can finally hand this off to our customer to add all that in.

With the background out of the way. My question is if this is Prizm error because nothing has been added or if it is a Rodopi error?

2007-05-23 11:22:15,932 [3572] INFO Rodopi.Integration.NetworkAccess.Provisioning.AccessDeviceSvc - AddAccessDevice: deviceId = ‘’, subscriberId = ''
2007-05-23 11:22:17,792 [3572] FATAL Rodopi.Integration.NetworkAccess.Provisioning.AccessDeviceSvc - Unhandled exception occured
System.Web.Services.Protocols.SoapException : java.rmi.RemoteException: Northbound Interface Not Available.; nested exception is:
java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.RemoteException: Invalid Service Name: Canopy.Prizm.NorthboundInterface
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke (String methodName, Object[] parameters)
at Rodopi.Integration.Motorola.Prizm.SDK.Network.NetworkIfService.getNetworks()
at Rodopi.Integration.Motorola.Prizm.Provisioning.WorkflowManager.GetNetworkIdByName(String networkName)
at Rodopi.Integration.Motorola.Prizm.Provisioning.WorkflowManager.AddAccessDevice(AccessDevice accessDevice, ServiceCollection services, Subscriber subscriber)
at Rodopi.Integration.NetworkAccess.Provisioning.AccessDeviceSvc.AddAccessDevice (AccessDevice device, ServiceCollection services, Subscriber subscriber)

Is the Northbound Interface enabled on the Prizm server? You have to explicitely turn this on using the server admin tool, and restart the Prizm server.