Script to edit config by SSH


We're looking for a way to make a one-line change to the config via SSH and save and apply that change.

Easy enough to do manually but we would like to automate this process as we have a lot of radios to modify.

Currently we use a Python script to SSH to AP's and pull various information off them using the 'show dashboard' command.

Unfortunatley, the Python module we use for this - Paramiko - only allows the issuing of one command before closing the channel.

Is there a way to chain CLI commands so that we can put the following commands on one line?

config set powerSequenceFactoryDefault "0"

config save

config apply

Or does anybody have a different solution or suggestion on how we might accomplish this?




This implementation works for us. Hope it helps.



Hi Luis

Just tested and that works.

Now to implement on all our radios!

Interestingly I had tried an implementation similar to this but couldn't get it to work.

Thanks for your help!


1 Like

That's great news Colin! Please take a moment to click on "Accept as Solution" on the post that solved your issue. This will help other community members know that there is a solution for your original query. 



Alternately, use SNMP:

snmpset -v2c -cprivate . i 0

snmpset -v2c -cprivate . i 1

snmpset -v2c -cprivate . i 1

which is the same (provided MIB files are installed) as:

snmpset -v 2c -c private powerSequenceFactoryDefault.0 i 0

snmpset -v 2c -c private cambiumpmp80211ConfigurationSave.0 i 1

snmpset -v 2c -c private cambiumpmp80211ConfigurationApply.0 i 1

And should be able to be shortened to a single line as:

snmpset -v2c -cprivate . i 0 . i 1 . i 1



It does not work for me sadly :(

I'm not able to make this script work, not so clever with phyton, could you please help me on this? 

It would be nice a "STEP BY STEP"

Hello Jose,

If you have your devices managed with cnMaestro, it would be much easier to just create a template that changes the value of the powerSequenceFactoryDefault, which controls enabling/disabling defaulting of the radio using the power sequence.

Template is as simple as this:

1 Like

Attached is a script i use to add Multiple SSID's to multple units.

1 Like

Hello! Thanks for the example script supplied by you! Use ansible to configure devices force 180. A problem occurred while configuring PPPoE: if you do not specify the parameter networkWanPPPoEAC and networkWanPPPoEService, the system by default sets value: Service Name: Access Concentrator and temp: Cambium, and the PPPoE session is not activated. In the web interface you can leave these fields empty and then PPPoE works. But via ssh, options networkWanPPPoEAC and networkWanPPPoEService not left blank, the system generates an error. Who faced how to solve this problem? Thank you!

You should have started a new question, but the answer is to either put your actual ac and service-id in or to use ""
You can not use " " (that is “space”) as then its looking for an ac/service-id with that name.

If you use "" with no characters inside, I get the error message: "Syntax error: Illegal command line" to use "" ("gap") in the string is filled in the gap.