selected AP's frequency is unslected during setup

We have had an issue with a few units being setup with cnArcher where the frequency of the AP we select is removed from the scan list at the end of the setup.

We are scanning for 30 MHz channels in 5.2 and 5.4 GHz only, and sometimes it hangs after the final step to complete setup.  If you get into the GUI and go to the radio config, all channels except the one for the AP we are connecting to is selected.  We have seen this on a few APs that are on different frequencies.  It isn't happening in all cases.

Not sure if relevent, we are using 450b high-gain radios (factory defaulted before setup), AES-128 encryption, 15.2 firmware, and an authentication key. We are currently not having cnArcher do cnMaestro onboarding.

Here is a picture of what we saw after setting it up for an AP on 5560 MHz @ 30 MHz channel size. cnArcher had all 5.2 and 5.4 frequencies selected to configure it.

Is this with the Android version (1.1.14) or the iOS beta? Can you send us the debug logs using the "Report a bug" option in the menu?

This is with Android 1.1.14.  We didn't see this until recently, so I don't know if it's the new version, or the new firmware 15.2.

Also, this is on a 450m.

I will send a debug over when we run into another install with this issue. Most of our installs are having this problem now, but not always.

When it's happened, we have tried multipe radios and multiple phones, all having the same outcome.

Do you get an error message from the app when this happens, so the installer is aware that something went wrong?

Will wait for the debug logs to investigate further.

Customers have reported similar issue when scan list is long. And we addressed what we could recreate in 1.1.14. We do test with 450b SM with all bands, all bandwidths and all frequencies enabled, which is the worst case.

There is no error when it happens, it just hangs on the final step: Connecting to AP (after everything has been done, and the name, etc is entered).

Here is one of the logs. It hasn't done it on every install, hopefully you can find it. When we run into it again, I'll post another debug log.

One of the installs with this problem should be on Mario's log on Sep 19th, around 21:00.

I will send the other in email, it's too large to attach here.

Thank you. I downloaded the log file and deleted it from the post.


We have fixed this issue. It happens when scan list is longer than 100 entries. Please try with v1.1.16 that is now available in the Play store.

was this issue fully resolved?

We recently started adding in 5.1 ghz channels to our default scan list as we are using that on a few sites, and we've started seeing this issue again...  

We're using 16.1 firmware and latest cnArcher (I'll have to have tech verify version number he has installed)

@Arakasi, we believe this issue to be fixed. 

To help us debug what you are experiencing, can you please click on the "Report a bug" option from the cnArcher main menu.  That will provide us some logs to focus on.  (You may want to reference this forum thread in the email.)

I tested the current version of cnArcher Android, version 1.2.10 with a PMP SM running 16.0.1 software.  I enabled 20 MHz channel bandwidth on all of the 5.7, 5.4, 5.2 and 5.1 GHz bands in the cnArcher UI.  After clicking the CONFIGURE SCAN LIST button, i navigated to the SM's UI and it confirmed that all of the channels had been correctly enabled.  Screenshots below.

I will get a bug report sent.

The issue seems to only be occuring when the SM has 16.1 installed on it. Even selecting the frequencies, the SM doesn't seem to see the AP (although some of our tech reports this is only happening on some of our APs, not sure if frequency related or somethign else).

Downgrading to 16.0.1 on the SM allowed it to see the AP with cnArcher and onboard.  I haven't had any issues with SMs already onboarded using 16.1, but we've run into a few trying to use cnArcher as a new install.

@Arakasi, can you clarify if the problem seems to be with the PMP SM or with cnArcher?

I understand you state you experience the problem when running PMP version 16.1. 

For example, if you temporarily eliminate cnArcher, run 16.1 on the SM and login to the SM's GUI and then enable the required frequencies and bandwidths, does the SM successfully "see" the PMP AP when viewing the "AP Evaluation" page in the SM's GUI?  

I used cnArcher to upgrade the SM to 16.1 and tried using it to configure/register to the AP with no luck. I then (after it was already upgraded to 16.1) manually went in and configured the SM to scan all frequencies in 20, 30, and 40Mhz. AP eval showed nothing at all. After using cnArcher to downgrade to 16.0.1, all worked perfectly. This was tested/confirmed with 2 different SMs. Bug report sent from cnArcher and references this thread ID.