Sip Stack Fail

Everything was working till I disabled Only Recv Request From Server once re-enabled the FXS1 was disabled. I have also factory reset the unit and this is what i see in the log. also a reset button for only the ATA in this device would be great.

<Mon Apr 18 14:52:05 2016> ipphone[16818]: ***system booting***
<Mon Apr 18 14:52:05 2016> ipphone[16818]: SW:142(120106174008)
<Mon Apr 18 14:52:06 2016> ipphone[16836]: UISignalControl[30][9000][30][9000][9000]
<Mon Apr 18 14:52:06 2016> ipphone[16688]: Wan If eth2.1 ip Change : -> MY IP
<Mon Apr 18 14:52:06 2016> ipphone[16818]: Local SIP Addr:MY IP
<Mon Apr 18 14:52:06 2016> ipphone[16818]: Start Init Sip Stack...
<Mon Apr 18 14:52:07 2016> ipphone[16818]: Init Sip Stack Fail


We do have a reset button in R201 , but not in R200.

Please share your firmware version.

Reset button that only resets the ATA and not the whole device?

Product Name: cnPilot R200P  
Hardware Version V1.3 
Loader Version V3.07(Aug 20 2015 17:38:07) 
Firmware Version 4.2.2-R1(201603161644) 
Device-Agent Version 2.28 
I have also downgraded the device to 4.2 and the ata still wont work and nothing in the log about the ata that i can find just says disabled, so i upgraded the device back to 4.2.2 and sip stack error is back.

Your issue is resolved.

Thanks for sharing the device access.SIP registration failed because host name was deleted from the device/config file.


"Init Sip Stack Fail" if host name is not available.Please do not delete hostname.Your device is registed now with SIP server.

The host name is located under what tab?

I rebooted the unit again because it said "FXS 1 SIP Account Status Disable" when I logged into it shortly ago and this shows up. <Thu Apr 21 09:17:51 2016> ipphone[17072]: Init Sip Stack Fail

uh uh uh.jpg

So, it is much easier to find the hostname in the config file then in the tabs which is eluding me.

For those who need a good text editor you can download and use this one for free with a nag screen.

I applied a hostname and bam registered, not to my knowledge did I remove a hostname from this device and definitely not in the config file.


I have checked your SIP FXS1 device is registered now.

Host name is present in config file and should not be blank like in your case - "HostName=". It should show


You do not need any special editor to check this.Just go to Adminsitration -> Management ->Config File Upload & Download and Download the config.cfg file and chel for HostName variable. Host name should not be poiting to blank.Host name should not have space also.

I have check you config file and its showing me the hostname what you have configured and SIP status is registered.Please let me know if you have any issue making SIP call.

I was recommending a text editor in case the EUs notepad showed the config file all jumbled.


Today I was removing some ata setting and in the process the ATA said disabled again so I downloaded the config file and the host name was GONE again. I know for a fact I did NOT remove it. So downloaded the config file and added a host name and uploaded the config to the R200 to get it to work again.

some problem here

Please check if hostname is empty , please share syslog messages and config file with firmware version.

We have fixed hostname problem in our new firmware 4.2.3 which will be releases soon in a day or two.

We have been waiting on a fix for this for some time and we need it ASAP. When clicking save on the admin page the hostname goes blank and sip fails. We can't change the password without downloading the config, modifying the password and uploading it again. This problem has made the boxes nearly unueable in a large scale deployment. We also need the boxes to look for a generic and default initial configuration before looking for a configuration specific to their MAC. I understand the goal is to have cnMaestro manage provisioning, howver we are not there yet, are we....


New fimrware "Software Release 4.2.3" with a fix for hostname is posted at our support site: