SNMP Firmware update via FTP

Grettings,

Im trying to update a ePMP 1000 device via SSH with snmp from a FTP server that is on a Mikrotik router.

But i have a problem with the command:

snmp set -v 2c -c communitywritestring 127.0.0.1 .1.3.6.1.4.1.17713.21.4.7.0 s ftp://192.168.10.254/ePMP-NonGPS_Synced-v3.5.1.tar.gz

The Mikrotik router doesn't allow the connection to the FTP server on it couse the Cambium device is trying to access it with no username or password and i can't find any way to add the username and password to the command.

Could you please help me and tell me how to add a username and password in the command with which the Cambium device would connect to the FTP server.

Best Regards,

Nikola.

Hi Nikola,

Did you try ‚Äúftp://username:password@ftp.ip/filename.tar.gz‚ÄĚ format?

Thanks,
Dmitry

Hi Dmitry,

Unfortunately it didn't work, it gives me an error "Syntax error: Illegal parameter"

The firmware im using on the Cambium device is 3.2.2 and i'm trying to upgrade it to 3.5.1

Also when i try to set the string to https://support.cambiumnetworks.com/file/62d311f50a23a7a7ffe1ca1126a017ce8ebe7578 , it gives me the error 2 - Unpack failed, damaged or wrong format package

If there is any other info needed please tell me. It would be great if we could find a way for this to work.

Best regards,

Nikola 

Dmitry,

I found a way to upgrade the device,

Since my company uses a CNS Server i initialized an upgrade of an device from the server and connected to the device via SSH. Than i used the next command to get the string value while the device is working on an upgrade

snmp get -v 2c -c readcommunitystring 127.0.0.1 .1.3.6.1.4.1.17713.21.4.7.0

and got this string http://serverip:80/services/upgrader/backend/packages/ePMP-NonGPS_Synced-v3.5.1.tar.gz

After that i used this next command to upgrade other devices and it worked

snmp set -v 2c -c writecommunitystring 172.0.0.1 .1.3.6.1.4.1.17713.21.4.7.0 s http://serverip:80/services/upgrader/backend/packages/ePMP-NonGPS_Synced-v3.5.1.tar.gz

It would still be nice to find a way to connect to an FTP server with a username and password, so that we wouldn't be dependent on the CNS Server, but still this will work.

Anyway thank you.

Best Regards,

Nikola

Hello Nikola,

This command should have worked from CLI:

snmp set -v 2c -c private 127.0.0.1 .1.3.6.1.4.1.17713.21.4.7.0 s "ftp://ftpuser:ftppasswd@ftpserverip/ePMP-GPS_Synced-v3.2.tar.gz"

but it appears we may have an issue with CLI, as it is reporting that syntax error. We will have to look into that.

An alternative is to use snmp facility from a Linux PC. In such case, the following command should work:

snmpset -v 2c -c private deviceip .1.3.6.1.4.1.17713.21.4.7.0 s "ftp://ftpuser:ftppasswd@ftpserverip/ePMP-NonGPS_Synced-v3.5.2-RC10.tar.gz"

Regards

3 Likes

Hay otra forma de actualizar el firmware de equipos cambium que no sean con el CNUT ni via web?

probe las formas que mensionan en este foro y ninguna funciono.

toda la configuracion necesaria de mis equipos las hago via ssh y por lo mismo necesito que sea de esa forma la actualizacion del firmware.