SNMP issues with ePMP Software Release 4.7

So far no major issues on 1000, 2000 and 3000 APs with mix of SMs. Only issue we are seeing is almost all of our ePMP 1000 APs lose SNMP a handful of times throughout the day since our upgrade. We poll for frequency and attached SMs every 2 minutes. Prior to the upgrade, it would return an answer 100% of the time. Now, it returns an answer 80% of the time. Does not seem to be related to traffic or airtime utilization. We have a couple ePMP Force 180s used as point to point links and we SNMP monitor those APs as well - same issue. Pings never drop but maybe the CPU is getting too busy with the new firmware and ignores SNMP??

1 Like

@Au_Wireless,thank you for your feedback! I’ll check it in my lab

Could you PM techsupport file from 1 E1K and exact OIDs you are using.

I tried to replicate your issue with a script sending snmpget to E1K AP saturated with traffic every second. I asked 2 OIDs: .1.3.6.1.4.1.17713.21.3.8.2.18.0 and .1.3.6.1.4.1.17713.21.1.2.10.0. There was no missing response during 2 hours.

Do you use CnMaestro?

1 Like

Replied with tech support file. Just confirming it was received. We are definitely seeing SNMP timeouts on every ePMP 1000 device since 4.7.0. Equipment will stop responding to SNMP for up to 5 minutes at times. No issues with 2000 or 3000 series equipment.

1 Like

We began rolling 4.7 out this week and immediately began to have missing SNMP data in Zabbix. Just comes and goes now. No problems on 4.6.1 so I am having to halt deployment as we rely on SNMP data for monitoring. I did change the SNMP communities as required. Problem observed on 1000 & 2000 series APs. Have gotten gun shy and havent tried a 3000 yet.

1 Like

Hello @Charles_4,
we had a similar feedback some time ago. I did a test with E1K and E2K: a bash script made 2 snmmpget every second during 40 min. All responses were delivered. OIDs same as in customer’s report.

Could you try to isolate it? Weather it is Zabbix or our SW. You can try to do it the same way with a script. Zabbix is a good tool but it can also have some bug or wrong configuration. Is there any logs in Zabbix or misconfigurated communities? What exactly Zabbix does not like with 4.7

I need some clear steps to reproduce your issue. Preferably without Zabbix.
Thank you!

I did see that report from another user. And your follow-up of NOT being able to reproduce it. It does seem quite random and when I do a manual snmpget I have not been able to reproduce it that way either. The only change I made in zabbix, that was working flawlessly before, was to update the SNMP community. If I am able to provide any additional amount of information I will.

2 Likes

@Charles_4 at the same time could you send me a tech support file from 1 AP where you see the issue?

Did some one notice if there is some relation to SMs quantity? Maybe the issue comes after some certain amount of SMs is connected?
If you have a chance please try how GUI is working during this issue!

I will DM you with two tech support files from 2 of our APs that we see this on. One has 16 subs, the other has 19. We see it on every single 1000 AP we have so it is not related to SM numbers (some are pretty low). The GUI is almost unusable when SNMP stops replying. In fact, we see “connection temporarily lost” messages pretty frequently on 1000 APs since 4.7.0. GUI is incredibly slow all the time with 4.7.0 and slows down as traffic increases.

This issue seems to be either related to airtime utilization or throughput. We see SNMP stop responding when throughput increases but sometimes it responds fine with higher throughput levels.

Well, now that you mention that, I have an ePMP 1000 AP running 4.7 with only two customers and it has been fine! I upgraded it first because of the low numbers to make sure everything was fine. That being said, the second AP I upgraded is a ePMP 1000 /w only 5 customers and that one is having the SNMP drops.