Speed up large/complex BDC Exports by eliminating Shapefiles

The files generated for BDC exports in cnHeat are designed to be as flexible as possible.

There are files for ‘supporting data’, coverage polygons, and even 477 deployment data.


For coverage polygons we typically offer either a .gpkg format or a Shapefile format. (Both are identical, and the FCC accepts either.) However for large or complex exports the Shapefile generation can be slow and even cause the export to timeout (after 36 hours).

We offer a way to turn off the Shapefile generation when it is not needed. This can significantly speed up the export generation.

Just add the “|NO_SHAPE” (pipe symbol before ‘NO_SHAPE’) to the end of your job name to activate this option. This can be done either on Step 2 when submitting a regular export job or Step 3 when attempting a merge of multiple jobs.

Hello @Seth_Poche

We’re having the issue where our most recent jobs do not output any shapefiles or geopackages:

Any idea why this might be? We also have another job, identical to the one that didn’t generate a geopackage, that’s been stuck in “pending” for close to 48 hours:

Any advice on this is appreciated.



The lack of a single GeoPackage file and lack of a Shapefile is an improvement that we rolled out a few days ago. When an export is very large and covers a large geographic area we only provide the output as GeoPackage tiles. (See the “broadband_tiles.zip” file.) For our largest customers export jobs can timeout from Shapefile generation (which is a conversion from GeoPackage) and from trying to merge tiles into one single master GeoPackage. The result in these improvements are that jobs should run much more quickly. I will reach out via email to troubleshoot the Pending job.