Splash Page not showing

Hi folks,
I’ve configured four Access Points and onboarded them on the cnMaestro On-Premises. The issue that I am facing is that, when connecting with laptops the login Guest Splash Portal appears on the browser. However, when connecting on an android device it doesn’t. Just shows an error on the browser.
The four access points settings are configured through the cnMaestro controller. Their SSID are the same and are set to open.
1. Configured Splash Page firstly.
2. Configured Guest Access Portal. Under Access enabled Free and Voucher, set perimeters.
3. Under WLAN Guest Access, checked cnMaestro. Same WLAN set with the four AP.
Is it something to do with the cnMaestro firmware version? I’m just wondering. Firmware version: 2.1.0-r22
Or am I missing some steps when configuring the Guest Access Portal.
Any feedback would be much appreciated.

Getting guest login page on laptop means Guest Access Service is working. If we are not getting on Android phones means, Auto Detection of Captive portal is not working. Helps with 2 below information

1. Android version 

2. Screen error 

Thank for the feedback will take that into consideration.

Hello, I share my experience to try to save you some time and see if we can find a solution.

I have had the same problem, I have configured an SSID with splash page which works correctly on laptop but through Android it does not load and gives direct access to the network or shows an error message indicating that the Splash page was not found ... in my case, I configure free access by Facebook, Google, SMS and Voucher and I have tried each one separately and indeed they work, they all work correctly ... the problem is when the same splash page tries to use more than one method of access to it , that is, if I configure access with Facebook and Voucher-> It does not work .... SMS and Google-> it does not work .... Voucher and SMS-> it does not work ... the funny thing is that in all cases that I have tried it always works well on a laptop and it never works on Android ... this seems to be a cnMaestro platform malfunction that they still can't fix .... Cambium team please help !!!

Hi Gerachav,

Sorry for the inconvenience caused to you. Can you please provide more info to debug issue like:-

"Are you using CnMaestro Cloud or NOC, and which cnMaestro and device version are you using? All the mobiles getting same problem, or any specific android version mobiles only?"