Strict Nat on R190W despite port forwarding

I have a strict Nat type on my xbox, I have gone thorugh the port forwarding steps yet it still hasn't helped anything. My ISP now wants me to sign a security risk waiver in order for these ports to be opened up which seems ecsessive. Does this router not support UpNp? If port forwarding doesn't work on the router doesn't this mean it's an issue on their end? 

The nat type was Moderate for the longest time despite port fowarding, but after they did some work on the line it became strict.

Just trying to get some information before I have to get on the phone to argue with them that I shouldn't need to sign a security wavier to not have a strict Nat on my xbox in 2019. If any more information is needed about router settings and so forth let me know.

These router do support UPNP but it is disabled by default. I found you have to go under Application Tab, then UPNP tab and change the service to enabled to get it working.

I do not have that tab. Digging through the router a little more I think they did not give me one with a defaul login in. The username Iog in under (useradmin) only has four tabs. Here is what I found under the adminstration tab.

Yeah that looks like a user login and not admin login. They are probably going to have to be the ones to enable UPNP for you on the router.

Thanks for the help, it's seeming I'm just going to need a new ISP. They didn't try turning on UPnP until after I contested the "security waiver" and even now with that on and the ports open they can't get my NAT open and are telling me I need to get a $35/month static IP address to deal with the strict/double NAT. They are claiming xbox is "blocking" me which I know isn't true.

In my frustration I put my router in bridge mode as the xbox website I can't even get back to my router log in page haha

Hi ,

To Access UI of router in bridge mode there are two options.

1. Connect a client to lan port and assign it a static IP in subnet You can access router using from this client.

2. Configure first WAN port as INTERNET in bridge mode. Configure another WAN port as MANAGEMENT in DHCP-NAT mode. You wll be able to access UI through MANAGEMENT IP from WAN side.