Template for changing the center frequency and channel bandwidth of an AP from cnMaestro

This template is to allow a change of the “Center Frequency” and “Channel bandwidth” on your PMP450 series AP from within cnMaestro. This can be done on a per AP basis or as a bulk update if coordinating a frequency plan across multiple sectors/towers.

To add the template to cnMaestro, go to “Configuration > Templates”, and click “Add Template”, and then either upload the attached JSON file or paste the contents of the JSON into the text field and then click “Save”.

Once the template is uploaded, you can now configure the new bandwidth and channel you wish to change on a sector per sector basis by clicking on the “gear” icon.
Please note: Both variables are required to be populated for the template to save.

After you have configured all the sectors that require the new channel bandwidth or center frequency reconfigured, make sure to tick the box next to the AP to enable the template sync for the device.

You can either sync the template to the devices immediately or schedule them if you wish to run the configuration change closer to CPAS.

Please Note: This template has the “rebootIfRequired” flag set to “true” for use on the PMP450m AP. Changing the channel bandwidth on a PMP450m will trigger a reboot when the config is applied. The PMP450 and PMP450i do not require a reboot to change the channel bandwidth.

Template Details:

{
    "userParameters": {
        "radioConfig": {
            "bandwidth": ${Ch_Bandwidth}
        },
        "apRadioConfig": {
            "radioFreqCarrier": ${Center_Freq}
        }
    },
    "cfgUtcTimestamp": "2021-03-29T12:50:27Z",
    "configFileParameters": {
        "rebootIfRequired": true,
        "setToDefaults": false
    },
    "swVersion": "CANOPY 20.2 AP",
    "cfgFileString": "Canopy configuration file",
    "srcMacAddress": "0a-00-3e-aa-bb-cc",
    "deviceType": "3.6GHz MIMO OFDM - Access Point",
    "cfgFileVersion": "1.0"
}

The template has two variables, the first is for the “Channel Bandwidth” and the second is the “Center Frequency”.

The valid options for the “Ch_Bandwidth” variable are:

Channel Bandwidth Valid Variable
5MHz 1
10MHz 3
15MHz 4
20MHz 5
30MHz 6
40MHz 7

The valid options for the “Center_Freq” variable are:

Center Frequency Valid Variable
3555.0MHz 3555000
3557.5MHz 3557500
3560.0MHz 3560000
3562.5MHz 3562500
3565.0MHz 3565000
3567.5MHz 3567500
3570.0MHz 3570000
3572.5MHz 3572500
3575.0MHz 3575000
3577.5MHz 3577500
3580.0MHz 3580000
3582.5MHz 3582500
3585.0MHz 3585000
3587.5MHz 3587500
3590.0MHz 3590000
3592.5MHz 3592500
3595.0MHz 3595000
3597.5MHz 3597500
3600.0MHz 3600000
3602.5MHz 3602500
3605.0MHz 3605000
3607.5MHz 3607500
3610.0MHz 3610000
3612.5MHz 3612500
3615.0MHz 3615000
3617.5MHz 3617500
3620.0MHz 3620000
3622.5MHz 3622500
3625.0MHz 3625000
3627.5MHz 3627500
3630.0MHz 3630000
3632.5MHz 3632500
3635.0MHz 3635000
3637.5MHz 3637500
3640.0MHz 3640000
3642.5MHz 3642500
3645.0MHz 3645000
3647.5MHz 3647500
3650.0MHz 3650000
3652.5MHz 3652500
3655.0MHz 3655000
3657.5MHz 3657500
3660.0MHz 3660000
3662.5MHz 3662500
3665.0MHz 3665000
3667.5MHz 3667500
3670.0MHz 3670000
3672.5MHz 3672500
3675.0MHz 3675000
3677.5MHz 3677500
3680.0MHz 3680000
3682.5MHz 3682500
3685.0MHz 3685000
3687.5MHz 3687500
3690.0MHz 3690000
3692.5MHz 3692500
3695.0MHz 3695000
2 Likes

I always get error:

“JSON entered is invalid. SyntaxError: Unexpected token “ in JSON at position 2”

Ah, I see the examples above have typographic open and close quotes, but you actually need to use plain double-quotes (ASCII 34).

ie. instead of this:

{
    “userParameters”: {
        “radioConfig”: {
            “bandwidth”: ${Ch_Bandwidth}
        }
    }
}

you need this:

{
    "userParameters": {
        "radioConfig": {
            "bandwidth": ${Ch_Bandwidth}
        }
    }
}

I’ll see if I can fix the original post.

Are these values required:

"swVersion": "CANOPY 20.2 AP",
"cfgFileString": "Canopy configuration file",
"srcMacAddress": "0a-00-3e-aa-bb-cc",
"deviceType": "3.6GHz MIMO OFDM - Access Point",
"cfgFileVersion": "1.0"