Trouble with cnPilot file sharing

I am having problems reading a USB memory stick plugged into my cnPilot 201P router.
I have followed the set up from the link above. See screen prints


I have entered FTP:// as directed in both Chrome and IE and both report


I can’t help think I’m making a stupid error but can’t for the life of me see it.

When using and earlier router (BT) just plugging the USB stick in was enough for it to appear on other devices on my laptop. Is the CnPilot set up really this complicated.

Any help would be appreciated.

What do you get if you open the Windows Run… dialog ([Windows-key]-R) and enter \\ ?

Tried that and no response at all

Sorry actually got:

This is probably a silly question, but just to make sure: is actually the IP address of your cnPilot? Also, have you rebooted it since enabling the Samba server?

That’s the address I use to get to the router log-in and it works. I did have a problem some time ago where I need https:// in front of the address to get access, that no longer seems to be the case.

Yes I have re-booted.

Do you see anything in the logs (Status :arrow_right: Syslog) that mentions Samba or SMB?

I just tried by IE and Windows Explorer.
IE returned:

Syslog showed nothing, see below :

Thanks again


Further to my last reply and I really am out of my depth here!

The syslog message referring to is interesting as I don’t have a device on my network with that IP address. I have an app called Fing which maps all my devices and I’m happy it has found everything.
There were error messages earlier on the syslog, when I wasn’t trying to connect, as follows:


Probably totally unrelated certainly no mention of SMB or Samba.



I’ve just realised I should have been looking at the wrong end of the Syslog but there was nothing there either!

I’m running out of ideas, so I’m hoping either someone from the cnPilot team or in the community will chime in.

I notice that you’re running firmware version 4.4-R7. The most recent release at is 4.7.1, but a quick scan through the release notes doesn’t show anything related to file storage, SMB or FTP.

The fact that neither FTP nor SMB is working is interesting. Have you configured any firewall settings on the router?

It’s difficult to get good error messages from Windows. Maybe a proper FTP client (eg. FileZilla) could give a better error message?

I haven’t configured firewall settings on the router, don’t know where to do it.
I’m confuse (no surprise there) you say neither FTP nor SMB work. I know I have typed in FTP:// etc which I guess is FTP access. How do I attempt SMB access.

Excuse my ignorance!

SMB is the Windows file sharing protocol. It is what is used when you visit a network drive in the Windows File Explorer. This is what would have been used when you entered \\ in the Run… dialog. The error message you got (“The network path was not found”) suggests that your PC was unable to contact an SMB service running at that IP address.

FTP is a different way of moving files between systems. It’s not really integrated into Windows like SMB is. FileZilla is an example of a program that can use FTP to transfer files.

Web browsers have traditionally been able to perform a limited version of FTP; when you enter an ftp:// URL, they will try to connect to the FTP service at that URL. However, I think they might be starting to remove that support. It’s difficult to tell if the error message you received when trying the URL was due to the service not running, or due to your browser not really knowing how to do FTP. That’s why a dedicated FTP client would be a better test.

A small thought, that almost certainly won’t make any difference: you could try making the Workgroup in the SMB settings match your computer’s workgroup. I doubt it’ll make any difference because I don’t think the workgroup is used when accessing an SMB host via IP address, but it wouldn’t hurt to try.

Thanks once again for you help.

I have tried FileZilla and the response was:

Status: Connecting to…
Status: Connection attempt failed with “ECONNREFUSED - Connection refused by server”.
Error: Could not connect to server

Interestingly (I think) is that on my first attempt I didn’t enter the port number in FileZilla but it did return the one set on the router. I think that means the network is seeing it.

I have set up the FTP to be anonymous but I have tried adding the router login details but it made no difference.

I took a look at the FileZilla help for this message and temporarily switched of the Windows Filewall but that had no effect.

I also tried changing the Workgroup on the SMB tab but again to no avail.

I guess it’s time to admit defeat!

No, port 21 is just the default for FTP. The error is categorical: “Connection Refused” means that packets from your PC are making it to the device at, and the device is actively refusing them (it’s sending a response back saying that it won’t allow the connection).

Looking again at your first screenshot, I see you’ve entered a path with spaces in. I wonder if that could be a problem. Could you try removing spaces from the paths, both in the UI and on your disk?

Also, can you confirm that your drive is formatted as FAT32, as mentioned in this note:

Definitely FAT.

I didn’t enter spaces and there are none in folder names on the disk, is that what you mean?

Oh, sorry, I was referring to System Volume Information in this screenshot:


…but I realise now that that page probably shows what it has found on the USB drive, and System Volume Information is a directory that always exists.

Since there haven’t been any other suggestions here on the community, I suggest you raise a ticket.

Thanks for trying. I have an open ticket but less help than you. I think I’ll give up and manage without it.

Reluctantly today I updated the firmware on the router (probably I have been stupidly wary but I didn’t want to screw up my network).
FTP then worked fine with Filezilla and IE but not Chrome.
I shall shortly try and set up DDNS access which I have failed with in the past.
Thanks for your help.

1 Like

I’m glad FTP works for you now. I expect the reason for Chrome not working is that they have removed support for ftp:// URLs.

Does SMB also work for you now? ie. are you able to do this: